Characters missing while trying to enter string data using Type into

Hi,
I found an issue while trying to enter a string containing special characters to a combo box. I’m not able to enter ( and & characters to combo box. I tried the same in a textbox and got the exact value.
framework
I tried the same activity in another combo box but I can’t find the issue in it.
Editable Combobox With List Autocomplete Example | WAI-ARIA Authoring Practices 1.2.
I don’t know if it’s the issue of ‘Vaadin’ framework.
How can I solve it?

Hi @Gopalakrishnan_K

Can you please increase ‘DelayBetweenKeys’ and try? The default value is 10 milli second.

Thank you.

@Gopalakrishnan_K

Also you can try with Set Text Activity

Hope this will help you

Thanks

Tried setting delay up to 500 but not working.

Tried it but getting the same result

@Gopalakrishnan_K

Then there might be a auto limitation in the software might be?

Can you check manually entering?

Thanks

Special characters can be interpreted as specific hotkeys.
Possible workarounds:

  • change the input method to other options, such as ‘simulate type’
    image. This mostly avoids characters to be interpreted as a hotkey.
  • Use set text or slect item activities if possible
  • In the rare occasion that this all doesn’t work: use the clipboard.
    Paste your string to the clipboard using the ‘set to clipboard’ activity, and use ‘send hotkey’ activity (with ctrl-v) to paste the value in the target control.
1 Like

Set to clipboard worked for me. Thanks for the solution.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.