Can't use studio says no robot configured for current user

Can’t use studio says no robot configured for current user

I have gone into orchestrator and removed all machines and retried adding them

I’ve copied the machine key to clipboard and then gone into UiPath assitant->Orchestrator Settings. Selected connection type to machine key and copied it into the machine key field

and then hit the Connect button

and the status appears as connected unlicensed

If I try to open studio I get the message ‘No robot configured for the current user’

I have tried to follow the instructions but I am getting nowhere it’s very frustrating.

could someone please help me I really need to be able to use studio to do the training.

Many thanks,

Hi,

it might be license allocation issue. could you please share your screenshot for the robot section.

In that same window of uipath assistant you can see first drop down as Connection Type
Click on that and choose Service URL
This is a interactive way of sign in which will not require any machine key and it will ask you for the orchestrator url alone

Try that method and let know if you still facing the issue

Cheers @charliefik

Hi Kirankumar,

I think it is a licence issue but I’m not sure how to resolve it

This is a screenshot of the robot page at the tenant level

however when I set up the machine I set it up as a template (as suggested by the set up tool)

and if I click View Robots from here there are no Robots showing (as a filter for Machine has been applied) which seems like the machine doesn’t have an associated robot.

not really sure what’s going wrong here?

Hi Palaniyappan,

Thanks for the reply

I’ve got the connection type set as Service URL now and I’m still showing as Connected unlicensed

(I’m not sure if my previous new post with the new screenshots of machine and robot screenshots helps explain what’s going on, not to me)

Hi

Is robot created in your orchestrator
@charliefik

Hi,

sharing my thoughts over issue. In your machine page you created machine with your email id. you should use exact computer name (DESKTOP-COP1T60). once you create machine you should allocated developer license to it and after that create robot by using machine. go to assistant and try to connect with the machine name and key. Could you please try like that.

if it is not working try options suggested by @Palaniyappan . thanks.

When I set up the machine I was going to set it up as a standard machine, however a tool tip suggested setting up as a machine template (for modern folder set up see below)

So I didn’t do this I created a machine template instead (going to delete my current machine and re add a new machine template below screenshot of no machines after deletion)

then I add a machine template (this is what I entered before clicking provision)

this is the result. I get the chance here to copy the key associated with the template which should then be applied (to any machines with the key?)

Then I went to UiPath assistant and pasted the copied key into the assistant

and hit connect

At which point it says connected, Unlicensed

So the machine template didn’t work so I went to standard machine

I believe the robots are automatically created on this version.

Under Robots → Configured Robots, I have

Under Robots → Unattended Sesstions, I have this (which shows the robots as connected)

If I go back to my UiPath assistant

preferences, with the and try to connect with the machine key I get Status Connected, Unlicensed

and can’t open up UiPath Studio (nothing happens) after clicking signin

So instead if I go back to UiPath assistant and change to Service URL instead of machine key

and hit sign in I still get connected, unlicensed

I think it must have something to do with the licence allocation but I’m not sure how to resolve the issue (having removed all machines many many times now)

Shall we try only with the standard robot now. later we can configure with machine template. For standard robot configuration i am sharing very generic thoughts. trying to help you out.

Please go to your computer properties to get the accurate machine name. Enter that machine name in your machine settings.

For user name and password you have to enter your domain\ your username and enter your system password correctly.

Some where we are missing something here could you please double check your machine name, username and password you entered correctly while creating machine. thanks. please refer the below link.

Regards,
Kirankumar.

Thanks kirankumar,

That is what I tried, with a standard machine in my last post, but I will try again.

Here is the whoami

image

I’m restarting my laptop just in case that helps

I’m going to delete any machines from Orchestrator and start again from scratch and use a standard machine again.

Deleted machines so now nothing in machines

If I go to robots there is this in configured robots (don’t know why this is there, or how to get rid of it)

if I look at unattended sessions, user sessions or classic robots on this page they are all empty.

Now I’m going to add a standard machine (from the machines tab by clicking Add Standard Machine)
For Name I’m putting the whoami value, in Runtime licenses I’m setting Production(unattended) to 1 and Testing to 1 and then click provision

I now have 1 machine

I’m now going to copy the machine key and paste it into UiPath Assistant → preferences → orchestrator settings.

Change to Machine key, it has picked up the machine name (without the user name)

I’m using https://cloud.uipath.com as the Orchestrator URL

and have copied the machine key into the machine key field.

Then I click connect and the Status shows as Connected, unlicensed.

If I go to admin in cloud.uipath.com and click on the edit license allocation icon for my tenant

I can see my licenses for CE which should be sufficient to have 1 robot

If I go back to Orchestrator in my Tenant section I can still see the 1 row in configured robots (still don’t know what that is)

but now I have 2 rows in unattended sessions both say connected (I have got to this point several times before)

UiPath assistant still shows as connected Unlicensed

And if I try to access UiPath Studio I get this.

First a sign in and then when I copy the machine key into the box I get the message You are not authorised to perform this action

I really don’t know what to do to move forward here.

Hi,

i know your pain it will irritate us when we stuck a issue like this.

CMD-> who am i - your userid
CMD-> hostname - your Machine name

Who am i returns your domain\userid not the machine name.

Use hostname command instead of who am i to return your exact computer name.

Please one last try - use the machine name you have received from cmd via host name command while creating machine name in your orchestrator and the user id(the value return from who am i command) and your password.

if still facing issue our forum leaders or uipath experts should help you.

Sorry friend i am not helping you much in this issue.

1 Like

No, I absolutely appreciate your trying to help with this issue, thanks very much!

1 Like

Hostname returns DESKTOP-COP1T60 (capitalised version of the domain).

I’ll see what I can do with that in the machine name when creating it and see if that helps

Sure please try and let me know. Thanks@charliefik

So deleted old machine.

Created new machine with just the hostname value in name

copied the machine key to UiPath Assistant (still says connected unlicensed)

went to Orchestrator tennant

On machines tab

on robots configured

and on robots unattended 2 robots both showing as connected

on tenant licence

if I try to open studio it asks me to sign in and then after pressing sign in the page disappears and then nothing (window disappears and window with UiPath logo which then disappears thats all).

Hi @charliefik

Could you please show a screenshot of your user configuration from:
image

image

In theory, it should be as easy as configuring your robots under your user and then connecting to cloud.uipath.com via the sign in feature.

Hi loginerror,

Thanks for the response.

Here is my Manage Access

and then if I drill down into clarkcoleman@hotmail.com via edit



and if I check roles

and view profile

Thank you. Some ideas:

  • you could try selecting Automation Developer for your attended robot rather than relying on the group inheritance:
    image

  • you could try selecting the “Run foreground automations” and then setting up all the fields that will show up then
    image

Hi Loginerror,

I changed to Automation Developer and Run foreground automations (but I don’t really only want to be able to run foreground automations, obviously it’s better than nothing though)

Still can’t open studio after the login page (nothing happens after clicking on sign in looks like studio is about to open ‘splash page’ then nothing, as before)

Then I went to UiPath assistant and in preferences it still said connected unlicensed.

I clicked sign out and now it shows as connected, Licensed.

I don’t really understand why you have to sign out for this to work?

However I can now open up Studio again so I’m happy.

Thanks for your help (I did revert the run foreground automations to unticked again) but have kept it on automation developer (just in case).

Phew!!!

Thanks everyone for your suggestions!

2 Likes