Cannot run robot service

Hey there. I’m facing multiple issues with my robot.

  1. My robot service isn’t starting. Windows gives me an error when I try to start it manually. “Error 2: Cannot find the file specified for this service”
  2. I cannot interact at all with the “Orchestrator Settings” page in my UiPath Assistant. I see my machine name there. But cannot type in the orchestrator URL or the machine key. It also says “Service Unavailable”, most probably due to the first problem.

I wanted to uninstall and reinstall UiPath, but I see no proper uninstall executable. Could someone help me out here?

Check if the location of your service still points to the right location in your registry.
Because it says it can’t find the service location

1 Like

Yeah, it worked. I can now run processes from Studio. However, My UiPath Assistant has become Uipath Desktop Agent, and the Orchestrator settings page is totally blank. Has nothing on it.
Btw, on all the documentation I find the default installation directory is inside “C:\Program Files(x86)\UiPath”, but for me it’s totally different. It has been inside “C:\Users…\AppData\Local\UiPath”. Is this normal now?

I would check to see if you have multiple installations and also review how the Robot / Studio was originally installed.

There are multiple installation files (Community exe and Enterprise msi).
Community edition will install in user mode under the user’s appdata and does not register the robot as a service. It is expected that you would run the UiPath Assistant / Agent Desktop to run the service in user mode.

MSI you have the option of registering the UiRobot as a service as well as if you install with Admin rights it will be installed to Program Files otherwise it will be installed per user in the user’s appdata.

But how do I check the installations of the robot? They don’t show up in the list of installed apps in the default windows uninstaller, or 3rd party ones. Only studio shows up. And uninstalling that doesn’t remove the robot files. How do I go about doing a totally fresh install?

Robot is installed using the same package that Studio is installed with. Uninstalling Studio should also remove the Robot files.

PlatformInstaller (exe)

  • Studio
  • Robot
  • Orchestrator

StudioSetup (exe) / UiPathStudio (msi)

  • Studio
  • Robot

@rpa4
It worked? What did you change? I hope you didn’t change anything. You have to analyse first what the problem could be.

  • Was the registry set to ProgramFiles? and you are running community edition? > Then there is your problem. There is already a setup of uipath on your system.

I find the default installation directory is inside “C:\Program Files(x86)\UiPath”, but for me it’s totally different. It has been inside “C:\Users…\AppData\Local\UiPath”. Is this normal now?

Enterprise goes to Program files. Community edition goes to Programdata.

Are you and administrator on your own system, or do you have IT install software for you?
After this is clearified you can move to the next step

Orchestrator:

  • Create a machine (copy the machinekey), create a robot

Your system:

  • insert the url of your orchestrator
  • past the machinekey and connect.

Using community edition. I just changed the registry file path. It was pointing to a file in Program Files. I set it to the correct path in Users…\Appdata. I installed UiPath on this computer in August of 2019, and removed it about a week later, since I was working on my laptop mainly. I checked if there was a previous installation before installing it. There wasn’t.

So the robot service wasn’t removed then when you deleted it.

What problems do you still have now?

It’s fine now. Used a 3rd party program to remove all the contents, installed everything fresh. Works more or less properly now.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.