Unable to run or connect robot to orchestrator

Hello,

i installed the community version and when i open the orchestrator setting in the community version it get this error, when i run a blank process, i get this error.

Could not connect to UiPath Robot Service. Make sure the service is started!

Can some please help me?

I’ve already looked into few pages of Uipath support and did the following things

  1. Go to Windows Services (type “services.msc” on startmenu) and start the service named “UiRobotSvc”.

when i did this, it gives me new error saying file path not specified? is it possible to install only uirobot?

Hi @skumar2,

Welcome to Uipath Forum

Could you please try solution in below article:

Thanks,
Neelima.

I have tried all those approaches as you’ve mentioned, but none of them seem to resolve my issue

@skumar2

Welcome to community

For Installing only Robot, it is possible if you enterprise license

Can you share your error screenshot?

Thanks

I’ve attached three error screenshot:

  1. when i open Uipath
  2. when i open orchestrator settings
  3. when i run uirobot in services

@skumar2

Can you try uninstalling and restart your machine

Try installing it again with admin privileges also with open internet

Thanks

I have tried it as per your suggestion, it still doesn’t seem to work. Receiving the same error messages

Hi @skumar2,
First of all, welcome to the forum. Maybe try a different approach to get familiar with UiPath.

  • Install UiPath Studio
  • Build your first project, and run it from studio.
  • Publish your project and run it from the assistant
  • Configure a machine and robot in the cloudplatform and then connect your assistant to it.
  • Install a new VM or computer and install only the robot and connect that one to Orchestrator.
  • Build a project, publish it to orchestrator and run it on your robot from Orchestrator.
  • etcetera. You will find your way.

In this way you get used to the setup and parts of UiPath and make small steps forward.

  1. Install UiPath Studio. This has the assistant build in. (there is no robot service you have to start). After installation, start Studio and the Assistant and you are ready to go.

t_MaExOnftIM

  • You can test your projects in studio itself.
  • When you are ready, you can publish it. The package will be placed on your local drive and it will appear in the assistant, so you are able to run it from there.

When you build your first project and ran it in your assistant (or from Studio), you can move on to the next step.

  1. Open the cloud platform and try to connect your Studio Assistant (see step 1) to orchestrator.
  2. Setup a new VM or computer and install the robot only. Then connect it to orchestrator (like you learned in step 2 and 3). For a robot i use the platform installer for that.

So start easy and work your way up.

Can you try this to reinstall the UiPath Community Studio
First remove everything from UiPath. Also make sure to delete the directories

%APPDATA%\UiPath
%LOCALAPPDATA%\UiPath

In one of the links below you can also check for more directories to delete (or make sure they are not on your system).

Restart your system.

Check and verify the hard/software requirements:
https://docs.uipath.com/installation-and-upgrade/docs/studio-hardware-and-software-requirements.

download a fresh copy of the studio from the cloud platform:

or this page:


install it as a normal user (you can check if you are a local admin on your system).

Some references that might be usefull:

Another post that might help you with reinstalling.

I think this will give you some insight and hopefully a solution.

If you need more info or help. Please let us know. If it solves your problem, mark it as a solution. It might be usefull to others.

1 Like

Hello,

Thank you for your detailed steps.

I have uninstalled and installed the stable version from the could platform snip that you shared.

After installation, i went to start and opened UIpath and i see the error message as below.

Just a question. Did you checked all the information in the post i gave and checked all directories. Did you rebooted between the installation and afterwards?

For additional info check your Eventviewer if you can see anything appearing in the logs.

The problem is there are many topics about it. And there is not an out of the box solution. So be sure to check everything.

The Community Studio doesn’t need the robot service. It runs as local service for one user.
@loginerror Do you have more tips on this problem?

Hi @skumar2

Would you be able to provide us with the output of the UiPath Diagnostic Tool (should be available in the Start menu):
image

Please send its output over via a private message @loginerror.

As to the issue and possible causes - this seems to be highly irregular:

Mainly because there is typically no machine-wide service installed for the Community Edition, it is simply run as a process. Did you maybe have the Enterprise version before you tried to run the Community Edition? This could explain that.
Having both is not supported and might result in these types of issues.

Please double check if there is really no left overs in the Program Files folder, as well as via a simple Add/Remove Programs in Windows.