Cannot log events in Orchestrator after running Jobs

Hello! I have a problem with viewing logs, after i connect my robot to Orchestrator and run successfully the Job i cannot view any log, if i start the workflow from the robot tray the logs are stored locally in the virtual machine where the robot is running, but if i start the workflow as a job form Orchestrator the robot executes the workflow but there is no log anywhere. Inside my workflow i configured a Log Message and also i added Log Fields, the Robot Logging Level is set to Verbose and also tried with Trace, in the Robots Orchestrator Tab i turn on the robot logging level setting to on and Verbose but with no luck. The end goal is to view the logs from orchestrator and after pass the logs to Elasticsearch and finally to Kibana

Fine did we have a view on this folder for logs
C:\Windows\SysWOW64\config\systemprofile\AppData\Local\UiPath\Logs
And also ensure that the right machine and right robot is tagged together and along with that right robot is tagged to the process
So that when the process is run with that robot the logs gets created

Cheers @Bruno_Silveira_UY

Yes i can see the logs locally on the machine where the robots and the studio are (inside UiPath\Logs) but from the Orchestrator side the only thing that is not showing are the logs, all the other functions are working flawlessly.

So to view logs in the orchestrator for a particular process
Once after running the jobs in JOBS page click on the three dots at the right end of that job been ran
And click on VIEW LOGS that should show us the logs of that job ran
Cheers @Bruno_Silveira_UY

I already did that, i set the interval to All and the message displayed is “No data to show”, but in the folder AppData\Local\UiPath\Logs the logs are stored just fine. I also modified the Web.Config file of the Orchestrator but i don’t know if a have to change something else in there

Hmm
Ok so what was the modification made on it
Also ensure that we have changed the LOG LEVEL in robot tray at right Machine only then it will get reflected in the orchestrator and logs will be shown

Also in the orchestrator with View Logs page ensure that the drop down option like All log type is chosen and date as All chosen in the filter option
Sometimes we may miss with that

Cheers @Bruno_Silveira_UY

I changed the line “” to “”
i only added the “database” because it is what it says on the documentation: https://docs.uipath.com/orchestrator/docs/webconfig#section-robot-logs

Just did that and nothing

I tried that also

Hhmmm
That should work actually buddy
Fine may I know what is the edition of orchestrator like is it a community or enterprise edition
Are we using new cloud orchestrator with the url
https://platform.uipath.com
Cheers @Bruno_Silveira_UY

No i have the Enterprise version (2019.4.4), thanks for the help @Palaniyappan , i´m running out of ideas :confused:

1 Like

No worries buddy
Let’s check first whether w shave the access to see the logs
For that check with your role whether you have access
—for that go to the top right corner of the orchestrator page and click on the username and under that click in user and once user page opens click on roles tab and check whether you have got the access to VIEW THE LOGS

kindly check that once and let know for any queries or clarification
Cheers @Bruno_Silveira_UY

1 Like