Modify NLOG to communicate with orchestrator?

Hi again, i post a question earlier about this topic (Cannot log events in Orchestrator after running Jobs), but with no successful solution, so studying and testing the configuration and files i came across the Nlog file in the Studio installation folder, to my knowledge this file controls the creation of the robot´s logs, my question is, there is a way to modify this file to force the log to Orchestrator? No matter how configuration i change i can´t see the logs on Orchestrator.

1 Like

Hi
Let’s check first whether we have the access to see the logs
For that check with your role whether you have access
—for that go to the top right corner of the orchestrator page and click on the username and under that click in user and once user page opens click on roles tab and check whether you have got the access to VIEW THE LOGS

kindly check that once and let know for any queries or clarification
Cheers @Bruno_Silveira_UY

1 Like

Yes i´m the administrator, all the checkboxes are marked in the Roles tab

is the LOGS option is enabled with VIEW option
Cheers @Bruno_Silveira_UY

Hi @Bruno_Silveira_UY

Location of NLog file: \NLog.config

By default internal Robot diagnostic logs are sent to Event Viewer, as specified in the following lines from NLog.config:

Editing the NLog.config file requires administrator permissions. The UiRobot.exe service needs to be restarted if the Internal target is changed in the NLog.config file for the changes to take effect.

By default Robot Execution Logs are stored in a file in the %LocalAppData%\UiPath\Logs folder. The messages are collected by the Execution type logger and can be forwarded by using NLog targets, as specified by the following parameters in the NLog.config file:

If the Robot is connected to Orchestrator, all execution logs are sent to Orchestrator and can be seen in the Logs page.
Additionally, log targets and content can be configured by editing the NLog.config file.

Here editing the NLog.config file requires administrator permissions. The Robot service does not need to be restarted for the changes to take effect in contrast to diagnostic logs :slight_smile:

Hope this helps!

Yes. All the options are enabled.

@Amol_Deshmukh you just copy text from this Link just tried that and didn’t work either

Hmm…i wonder why it didnt
Fine buddy
is it community edition or enterprise edition
if its enterprise edition of orchestrator kindly raise a ticket to technical team

Cheers @Bruno_Silveira_UY

1 Like

I wonder that too! :confused:

Enterprise, just send a ticket to support! Thanks for the help @Palaniyappan ! Very appreciated :wink:

Can you please share screenshot of nlog config file, as I made similar changes in my project and it is working without issues

NLog.config.txt (815 Bytes)
There is the file @Amol_Deshmukh

Hi Bruno,

Please follow below steps:
Step 1) first enable nlog in web.config file
Step 2) in nlog file provide customize log file path if required.

If it is still not working in that case you have to replace web.config

How do i do that? it is not already enabled by default in the Web.Config?

How do i customize the Nlog file if i want to pass the logs from the robots to Orchestrator when they are in separated machines?

Please go through below link, by default it is disabled

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.