Cannot find UI element coresponding to this selector

selector
uiautomation

#1

Hi. Newbie here. I tried my first webscrap and immediately ran into an error relating to the website url. Can anyone tell me where I have gone wrong?

Main has thrown an exception

Message: Cannot find the UI element corresponding to this selector:

Source: Attach Browser ‘financial Page’

Exception Type: SelectorNotFoundException

UiPath.Core.SelectorNotFoundException: Cannot find the UI element corresponding to this selector: —> System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector:
at UiPath.UiBrowserClass.Find(String bstrSelector)
at UiPath.Core.Browser.Find(Selector selector)
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)


#2

Hi @dman have you installed all the packages ??Is it community version,trail or licensed version??
Can you share some screenshots of the workflow!!


#3

Hi @dman

Actually the problem is when you are using Attache browser activity then you have to indicate on that webpage area not while IE window.
Second thing the problem is related with Selectors so will you please share that selector here so will be able to tell you the exact reason.

You can also share steps or your sample workflow here.
Regards…!!


#4

Hi. I am using the communit version. I don’t know if I have installed packages or not - that answer is probably know to that. How do I install them? I hope I have shared the right picture.

thanks for your help


#5

Hi. I am using Chrome as the Browser for scrapping and I have Uipath extension for it loaded. Here is a screen shot of my process (or what I believe to be my process)

Thanks


#6

HI @dman

You can install and updates packages from package manager. you will find this in Activities Bar . above the search bar for activities in the end. You have to expand your left sidebar to see it. :slight_smile:

If you are Using Letest Version then you can use this Shortcut Key To open package manager ctrl+p

Can you share your workflow or may be url something you are trying and on which section?

Regards…!!


#7

Hey @dman

What i said above in the following post was the only reason i guess. i have faced such problem in my earlier days.
and from your screen shot i can see that you have indicate the whole chrome browser with “attach browser” activity so reindicate with only that container of a tab.

Regards…!!
Aksh


#8

hey, I am also having this same issue. Cannot troubleshoot .

Can you help me out? The data is scrapped fine and once I run it I am getting this error.


#9

Hey hi @amithvs. I have a similar issue now. How were you able to resolve it? Can you please share?

Regards,
Komal


#10

for me a restart did the job. I restarted and installed the packages again and used uiexplorer to get the selector.


#11

Issue is because of Attach browser selector. How to avoid it. m also facing same issue.

Please help me it.


#12

@Bharti_sanghmitra use open browser and inside that use attach browser


#13

i tried , but still getting same error.

PFB Screen shot:

image

My workflow is:

Kindly help in it.


#14

@Bharti_sanghmitra use open browser activity in this output property create variable (chrome_session) and use attach browser in attach browser inside input property there is Browser here pass variable created in open browser (chrome_session)


#15

Hi Indra,

again getting error did according to ur steps:

Plz explain why need to create variable for browser?
and why still it is not working.

  1. created a variable in output
  2. use attach browser in attach browser inside input property there is Browser here pass variable created --> throwing error Overloaded groups are configured

Erased 2 step and it worked fine.


#16

@Bharti_sanghmitra If you create variable than you can use that variable in attach browser,close browser…can you share the selector code which is in attach browser


#17

Plz find attachment.


#18

Remove attach browser and you can use only click activity


#19

How can i remove it ? whenever i start recording it comes first inside that other activities are. If i remove attach browser other recorded activities also get erased.

Can u plz share steps how to do that?


#20

You are indicating wrong instead of whole browser window try to inspect only that web page body and let me know :slight_smile:

Regards…!!
AKsh