Level 1 RPA Developer 2018.3 - Lesson 6 Selectors - Attach Browser Error: UiPath.Core.SelectorNotFoundException

Hi,

I am stuck on practice 1 for Lesson 6 - Selectors (Level1 RPA Developer Foundation Training 2018.3).

I tried running the answered practice, and same error.

Getting this error:

19.2.0+Branch.master.Sha.21b678a4c3a8b1362fcdd6e92496f991e5a7da37

Source: Attach Browser ‘chrome.exe Generate’

Message: Cannot find the UI element corresponding to this selector:

Exception Type: UiPath.Core.SelectorNotFoundException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
UiPath.Core.SelectorNotFoundException: Cannot find the UI element corresponding to this selector: ----> System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector:
at UiPath.UiBrowserClass.Find(String bstrSelector)
at UiPath.Core.Browser.Find(Selector selector)
— End of inner ExceptionDetail stack trace —
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

This is the selector:

This is the site I have it ready open to extract the info.
-> www.fakenamegenerator.com/gen-random-br-us.php

Can someone please help?

Thanks,

Mikael

Refer the below workflow

Test (3).xaml (10.5 KB)

Thanks for your reply. I am still getting the same error.
By the way, I tried with Chrome.
Your example, I tried it with IE 11, and same error.

In Attach browser, what is your browser type “Chrome” and did you run the same workflow which i have provided and still you get the error.

Yea, that was the reason. I selected Chrome and it worked.

Thanks.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.