Cannot delete or edit argument

studio
arguments

#1

Hello,

I’m experiencing a really weird issue with regards to arguments. I have an ‘invoke work flow’ activity and I’ve been using “import arguments” to list the arguments needed. All worked fine recently up until one argument that I’ve inserted - I can no longer delete it from the list, or edit any of the values in the row. Every time I do and click ok, it just reverts my changes back to what it was like before clicking on the import button.

Any ideas?
Thanks


#2

@blueprintChris - Chris, This is really weird.
I have couple of points as follows:
Idea1: if you have back up script then try to recover from the same.
Idea2: Remove script from the current folder and copy into different folder and try to use it.
Idea3: try to Ctrl + Z on your script and save it. so that all changes will get reverted.
Idea 4: close every thing and restart your machine and try again. Please make sure you take a back up on different machine.
Idea 5: please run virus scan your machine.

Hope my inputs are useful.


#3

Hi,

I discovered that this was down to the arguments that are within the xaml file. So I can only alter the existing arguments within the arguments pane on that file, instead of being able to alter them on the Import Arguments window. I found this an odd bit of functionality but it seems to have worked.

Cheers


#4

Import arguments means left hand side activities pane ? you can’t modify on the left hand side. That will be only for showcase and can drag and drop as you need for main flow creation


#5

No, Import Arguments as in clicking Import Arguments on the Invoke Work Flow activity to bring up the window of arguments.


#6

Import arguments repopulates the list based on arguments of the workflow you’re invoking.
The changes you’re doing are being saved, but are overwritten next time you press Import Arguments.
If you want to edit the arguments instead of reimporting the list of them, use Edit Arguments.


#7

Spot on, thanks alot!