Cannot create unknown type '{http://schemas.uipath.com/

Hi

I have a robot which could be run in the studio but when I publish it and try to run it in the robot, I get the message:

An error appeared while executing ‘robot_name’
Error message: Cannot create unknown type '{http://schemas.uipath.com/workflow/activities}ExcelApplicationScope".

I have read the familiar topic in the forum but didn’t find an useful answer, do you have any idea?
(All the packages are updated to the latest version, and I have checked the project.json file and found nothing odd.)
Thanks!

before you run the bot validate the XAML File bcz either the dependency Package is not added or the updated package is not supporting the previous package activity.

I have checked all the packages and their versions but didn’t find anything wrong. Is there any other possibility or solution?

@AaronWei In the output panel you can find error message in red colour can you capture and share screen shot here

Hi @AaronWei

This is due to the Robot not having access to your local packages. See here:

One other possible solution is also here:

1 Like

I don’t use Orchestrator, there’s only studio and robot on the computer.
And I have checked ‘project.json’, <C:\Program Files(x86)\UiPath\Studio\Packages>, <C:\Users"UserName"\AppData\Local\UiPath\Activities>, the version of packages are all same.

1 Like

I can run it in Studio but cannot via Robot, so there is no error message in the output panel.

Hi Guys, any solution ?

Try this, Check that you have a reference to a local activity feed in the Nuget.config file in the following locations:

  • C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\NuGet
  • C:\Program Files (x86)\UiPath\Studio.
  • C:\Users%userprofile%\AppData\Roaming\NuGet

Keep at least one feed active, if local feed is not present, add it, like so
image

1 Like

Thanks, @byuli! By following your suggestion and editing Nuget.config in the Robot-only machine I was able to avoid the error I was having ie. custom package not being recognized by Robot and Robot issued an error “Cannot create unknown type”.

I read several posts and explored different alternatives but this was the one that solved it. Thanks again.

2 Likes