Cannot create unknown type when running via Orchestrator

I created a robot which works fine locally in Studio.

If i publish this robot to the orchestrator and i execute it on the same machine (studio-machine) it shows this error:

message: “System error at initialization: Cannot create unknown type ‘{}ReadRange’. at Source: UiPath.Core.Activities”

which seems like Excel-ReadRange is not working.

Sure i tried reinstalling / downgrading… this package, but same result.

Any ideas?

Hi @markus

You should see here for more information:

It seems that the packages needed by your processes cannot be properly downloaded to this .nuget folder upon run from Orchestrator.
You can try copying them to there from your UiPath installation folder and give it a try :slight_smile:

Also, see here for a response about similar issue:

thank you for your reply… now i could localize the error a little bit more…

in the

USERS \ .nuget \ packages

folder i can see some packages, but the standard-uipatch-excel-package is missing.
Do you have ideas why this is not added? In the project.json (dependencies) the standard-uipatch-excel-package is listed.

Where can i see where the robot downloads the packages? From Orchestrator or from web?

Some packages are downloaded some are not…