Cannot connect to the packages feed, the URL may be invalid - Troubleshoot Steps

Issue Description

Already setup orchestrator and already connect the robot.

When we publish the test project. This is successfully published based on the robot prompt but we cannot see the published package name at the Orchestrator.

Troubleshooting steps (Solution could be either of the two described below)

In the Event Viewer, one can see the error stating that access is denied for the folder in Orchestrator.

Resolution 1#:

The deployment URL needs to be empty by default. Please remove the url in case if you have provided any.

Resolution 2# :

  1. Navigate to “C:\Program Files (x86)\UiPath\Orchestrator”.
  2. Provide read/write permission / full control to “NuGetPackages” folder to “Everyone” or to that specific user from security tab.
  3. Shared the folder over network using advance sharing option
  4. Restart the AppPool and try again to publish the package from studio.

Verify the Nuget packages path from the web.config file: key Nuget.Packages.Path (One need to grant the above full permission to the mentioned path location in the web.config)
Please refer to screenshot below, below screenshot is the default values.

Hi PrananyaSahu,

was it resolve ?

Im current facing similar issues, where it can get the packages from Activities feed but not from the Orchestrator feed