Unable to publish project on orchestrator

Hi,

I am trying to publish a project on orchestrator and I am getting an error Publish of workflow project to orchestrator failed. Cannot connect to package feed, the development setting may be invalid.

Just for information, I had developed the project on an older version of studio and updated the studio now to 2019.4.2.

Please help.

1 Like

Hi @mohammedamaan,
Please disconnect Robot from Orchestrator, connect it again and try if it will work.

It’s still the same. This is only happening for the old project which i created. Any new project which i am creating is successfully getting published.

You can try do this:
Backup json project file. Remove it from project folder and load you project from Main.xaml file. New json should be generated. Then check if you project has all necessary packages and consist of all xaml file in the Project pane. And try again to publish it.

It’s still the same. Is it because I am using some custom packages?

My custom packages were not imported and i had to import them again.

Yes. Json file is having information about every dependencies so by removing it there is need to download again necessary packages again for the newly created json.

Alright. But still it did not help. I am still getting the error.

One more thing. Please tell me if you are using CE or EE version of studio? If EE are you using your own Orchestrator deployment?

We are using EE version. And yes we are doing on our own the Orchestrator deployment.

Ok. Maybe it might be that you tenant can’t properly connect to feed because of cache file is being corrupted. Please try this:

  1. On Orchestrator machine go to "C:\Program Files (x86)\UiPath\Orchestrator \NuGetPackages\Tenants’[TenantName]’ " (tenant for which your problem is occurring)
  2. Remove ‘[MachineName]’.cache.bin" (you can do backup somewhere)
  3. File will be generated again automatically when needed.

Hope this will help.

I only have a folder named ActivitiesSource under NuGetPackages folder.

Are you sure that you are checking it on server where orchestrator is installed? Please also tell me which version of orchestrator do you have?

Yes. I am using 2019.4.2

Hmmm very strange. Can you go to development settings in Orchestrator and show me your settings. Please just remove your API Key from screenshot.

Sorry for such image as i do not have direct internet access on my machine.

If someone can help as this is really critical

Probably is because your internet connection. Can you try in a computer with internet connection to do the same?

@mohammedamaan,
Sorry for silence. I’m trying to figure out is as well.
Can you please also meantime open ticket for this as well in our: Technical Support?

I’ve already raised it.