Cannot connect orchestrator to Robot

Hello, new to the platform.

I tried everything I could but I’m still missing something. I cannot connect the Orchestrator community license to the robot on my computer. I get the error below. Please help.

I did verify the machine name, the username, the password and the machine code.

Thanks!

Error:
The operation was canceled.
System.OperationCanceledException: The operation was canceled.
at System.Threading.CancellationToken.ThrowOperationCanceledException()
at System.IO.Pipes.NamedPipeClientStream.ConnectInternal(Int32 timeout, CancellationToken cancellationToken, Int32 startTime)
at System.IO.Pipes.NamedPipeClientStream.<>c__DisplayClass21_0.b__0()
at System.Threading.Tasks.Task.InnerInvoke()
at System.Threading.Tasks.Task.Execute()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Ipc.NamedPipe.NamedPipeClient1.<ConnectToServerAsync>d__5.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at UiPath.Ipc.ServiceClient1.d__20.MoveNext()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Ipc.ServiceClient1.<>c__DisplayClass17_01.<b__3>d.MoveNext()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Ipc.IOHelpers.d__6.MoveNext()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Ipc.IOHelpers.d__11`1.MoveNext()

Hi,
I had problem to connect too, In my case, the machine name was incorrect.
Check using the command: whoami
It result a different name that show in system properties.

Thanks for the reply. I already did that but I still get the error. This should be a very easy step. Not sure what’s going on.

Hello @Tex_Willer

Can you share some screenshots of your orchestrator robots page and a screenshot of the local robot tray settings page?

This will help us locate the problem

Hello, I think I have made some progress. After running the Robot version 2019.9.2 with the Community Orchestrator 2019.9.32 I get “Invalid machine key”.

Any clue?

Ok, it works now. It would be nice if the documentation was accurate. I had to use https://platform.uipath.com / < account name > / < service name > (remove the spaces, this thing is stupid…;-)) instead of the simple https://platform.uipath.com as specified everywhere else. Unbelievable.

Thanks to Pablito https://forum.uipath.com/t/not-able-to-connect-with-the-orchrestrator/153809/11

1 Like

@Tex_Willer

Yeah… that change came up pretty recently after they migrated to cloud. I think the idea behind is, if you see, we can have more than one orchestrator instances. However all instances share the same url if use the previous url. Since we can have multiple, I think we should have those parts in the url as well

Hi
welcome to uipath community

kindly have a view on this thread that could surely help you resolve this

Cheers @Tex_Willer

Hi @Tex_Willer,
Actually documentation is actual. Please have a look here:


But if you found somewhere on our site old information about connecting robot to orchestrator please let us know. :slight_smile:

1 Like

I cannot connect uipath to orchestrator, No error listed. When I try to run, the message appeared killing processes