Robot not connecting to a standard machine

I have tried to set up the robot to connect to orchestrator, but it is staying offline. When I set up the machine, I copied the URL perfectly and the machine key, but get a huge stack of errors.

System.OperationCanceledException: The operation was canceled.
at System.Threading.CancellationToken.ThrowOperationCanceledException()
at System.IO.Pipes.NamedPipeClientStream.ConnectInternal(Int32 timeout, CancellationToken cancellationToken, Int32 startTime)
at System.IO.Pipes.NamedPipeClientStream.<>c__DisplayClass21_0.b__0()
at System.Threading.Tasks.Task.InnerInvoke()
at System.Threading.Tasks.Task.Execute()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Ipc.NamedPipe.NamedPipeClient1.<ConnectToServerAsync>d__5.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at UiPath.Ipc.ServiceClient1.d__20.MoveNext()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Ipc.ServiceClient1.<>c__DisplayClass17_01.<b__3>d.MoveNext()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Ipc.IOHelpers.d__3.MoveNext()
— End of stack trace from previous location where exception was thrown —

Please help. I just want to finish the robot/orchestrator training, and the crazy thing is that I had it working a few days ago.

2 Likes

@jneedleman713
Hi have you read this article ?

cheers :smiley:

Happy learning :smiley:

2 Likes

I copied the same URL that worked less than 5 days ago, and multiple combinations of it, but it is not working now. I don’t know what else to try.

2 Likes

Hi @jneedleman713,
First of all please check if firewall is not blocking your connection somehow. Then please try again from scratch. Create machine (remember that machine name needs to be the same as your actual pc name to which you will connect), then create a robot and attach it to the machine, then copy machine key and in tray robot configuration enter machine key and address like:
https://platform.uipath.com/[AccountName]/[ServiceName]

2 Likes