Bot works in attended mode but not in unattended mode

Hi All,

I’m developing a bot that should enter text into a field. It works perfectly when I open the VM(Remote Desktop) on the foreground and watch it running, no matter running it from Studio or from Orchestrator.

However, if I do not put the VM in the foreground, if won’t be able to locate the text field.
Error Message: Type Into ‘INPUT identifierInput’: Timeout reached.
What’s more weird is, as shown is the screenshot below, the bot should have confirmed that the field exists otherwise it shouldn’t try to type into ‘INPUT identifierInput’.

If I run the process from orchestrator and wait until the bot is stuck with the type into activity, and then bring the VM to foreground. I can see it start typing.

I tried to take a screenshot to see what exactly is happening. But the take screenshot activity also doesn’t work in unattedned mode…
Error: Take Screenshot ‘BODY’: System.ComponentModel.Win32Exception (0x80004005): The handle is invalid at System.Drawing.Graphics.CopyFromScreen(Int32 sourceX, Int32 sourceY, Int32 destinationX, Int32 destinationY, Size blockRegionSize, CopyPixelOperation copyPixelOperation) at System.Drawing.Graphics.CopyFromScreen(Point upperLeftSource, Point upperLeftDestination, Size blockRegionSize, CopyPixelOperation copyPixelOperation) at UiPath.Vision.UiImage.FromScreenRegion(Rectangle region) at UiPath.Core.Image…ctor(Region screenRegion)

So there is like a quantum physics duality stopping me from observing what is really happening.

Please share your thoughts on this issue. Thank you!


The following might help you.


Hey @1111141

Element exists will find an element regardless of whether if its minimised or in the background. So it is likely working correctly as in, its ‘found’ the elements but the “Type into” cannot find the field.

Have you tried testing other options with the “Type Into” properties? (Can you paste your “Type into” Properties panel?)
I would test with these settings:

I would also consider adding a Try Catch to handle the exception with some more steps to empty the field and give you another chance to try something else (attach window and try a default hardware type into…)

Hopefully this helps you :blush:


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.