BOT get stuck on excel application scope

Hi Guys,

I am facing an issue while i execute a BOT, my BOT gets stuck when it comes to excel application scope activity. i have reinstalled packages, reinstalled my studio but still nothing works. i am facing this issue from today before it was running properly. when i restarted system once it worked for 1hr but again its not working. it looks very different i am not getting any error also its just getting pause thats all. But instead of excel application scope if i use workbook activity it works but i want to use excel application scope

Uipath studio version -2020.4.3 CE
excel -2016

kindly help me

@loginerror @Palaniyappan @lakshman

2 Likes

Hi @Abisha,

Can you check whats the system utilization when the process is running, kindly ensure that there are no multiple instances of Excel process running, that might be the unresponsive process.
Check your registry entries also, regarding the Excel version, if it shows multiple versions, its better to uninstall, clear entries and re install.

Hi Shiva,

i don’t have multiple process running, for the excel version let me check and revert back thanks

@Abisha

Can you run this file using start process and do a click anywhere on any cell in any sheet, and see if it works, It will help us understand whether it’s an issue with file or Excel package itself.

  1. You are using excel 2016, just downgrade your excel package 2.7.2
1 Like

Hi
try with downgraded version of excel activities and workbook activity is very fast in reading the workbook files, but may i know why we don’t prefer that…
are we using any execute macro or invoke vba…only then we need to consider excel package without choice…else its completely fine to go for WORKBOOK activities

Cheers @Abisha

1 Like

Hi, check your packages to be sure not having any previews or beta versions:
image

1 Like

Actually i tried downgrading packages it didnt help to resolve the issue. i cleared all the cache everything and i reinstalled also but it didnt work. sometimes when i restart the system it works fine.

And why i want for excel application scope is my previous project is developed using excel application scope activity so cannot change in all the places

1 Like

Fine
pls downgrade to 2.8.5 version of excel package and try again

Cheers @Abisha

Still it is not working. below is the error which i get in studio log file.

[ERROR] [UiPath.Studio.exe] [1] System.IO.FileNotFoundException: Could not load file or assembly ‘UiPath.Platform, Version=20.4.0.0, Culture=neutral, PublicKeyToken=null’ or one of its dependencies. The system cannot find the file specified.
File name: ‘UiPath.Platform, Version=20.4.0.0, Culture=neutral, PublicKeyToken=null’
at UiPath.Studio.ObjectBrowser.Workflow.Services.ObjectBrowserWorkflowService.IsObjectReferencesDesigner(DependencyObject activityDesigner)
at UiPath.Studio.ObjectBrowser.Services.ObjectBrowserDesignerService._designerPropertyGridService_SelectionChanged(Object sender, PropertyGridInfoBarEventArgs e)
at UiPath.Shared.Events.EventExtensions.SafeInvoke[TArgs](EventHandler`1 handler, Object sender, TArgs args)

, HResult -2147024894

1 Like

Uninstall and reinstall the excel package of that version again and try pls

Cheers @Abisha

1 Like

I tired this also didn’t work for me. please find the below

I tried that also it doesnot work. i am really not sure why suddenly it started happening. it doesnot throw any error also, excel application scope reading, writing nothing works

Still getting the same error, i downgraded to 2.7.2 and 2.8.5 nothing works. i reinstalled uipath by clearing all my previous packages everything it is not working

Hi, as a test, if you do like this, does it work?
image

1 Like

Yes it works

So, if you use the Excel Scope with visible = true and no activity inside, does it also open the Excel?

No it doesnot opens excel. the main part is some time it works and some time it doesnot works

Is your Office installed in 32 bits or 64?