UiPath.Excel.Activities v 2.9.3 [Excel Application Scope: COM object that has been separated from its underlying RCW cannot be used.]

I have a question regarding the latest UiPath.Excel.Activities update [v2.9.3].
Recently, our bots have started to stuck when working with Excel Application Scope.

In order to avoid such behavior, after each Excel Application scope activity a powershell script is called, which kills the excel process. (Description of a simplified version of the solution that is implemented and works

the description of UiPath.Excel.Activities v2.9.3 states the following

Fixed an issue that caused the Robot to sometimes get stuck without throwing an error when executing Excel activities, for example when an [Excel Application Scope] activity was used in a loop, or when multiple Excel Application Scope activities were used consecutively in the same process.

but now, my test flow, which I wrote to test the powershell script, [sometimes] throws the next exception.
**

Excel Application Scope: COM object that has been separated from its underlying RCW cannot be used.

**
that is, before v2.9.3 was installed, I had to call a script that kills the excel process.
Now, It looks like, I have to use a retry for each Excel Application Scope

could there be other reasons for this error?

Studio 2018.3.1 - 10/17/2018
Enterprise Edition
Windows Installer

Expires in 3 weeks

Microsoft Windows 10 Enterprise 64-bit
.NET Framework Version 4.7.2 or later


“dependencies”: {
“UiPath.UIAutomation.Activities”: “[18.3.6864.20582]”,
“UiPath.System.Activities”: “[18.3.6864.20561]”,
“UiPath.Mail.Activities”: “[1.2.6863.29868]”,
“UiPath.Excel.Activities”: “[2.9.3]”
},

@yaniketz

From you studio version, you are using very old version and you are you are using latest packages which will conflict

better to upgrade your studio and use the latest packages OR use what ever packages is suits to your studio

Hope this helps you

Thanks

Thank you for your advice, but
“Activity package versions are independent of Studio, Robot, or Orchestrator versions”

also I can update UiPath.Excel.Activities to 2.9.3 through “Manage Packages” option. There are no restrictions or warnings.

Also I can’t find them here

if I miss something when working with the documentation, please indicate it.

@yaniketz
Can i assume that the previous version of the Excel activity is not causing major issues for you? Which version did work? 2.8.6 or lower?

Are you using multiple application scopes in your process?
Are you trying to kill the Excel Application Scope within your process or after the complete job is done?
Are you still using the powershell script to kill the process, or are you using the kill/stop process from the uipath activities?
Can you share the powershell script?

I’m not aware of this issue, so if you could explain more, we might can give you advise on what to do.

The excel activity isn’t depending on the studio or robot version indeed.

Regarding if you are using an old studio or bot version, be aware when you are using enterprise versions which are EOL, you won’t get any tech support from Uipath. They will advise you to upgrade.
Keep the product lifecycle in mind


2018.3.3 has already passed Extended support.
1 Like