Automation only working under Orchestrator when viewed through remote desktop

I have encountered a really bizarre bug, and wondered if anyone else might have some insight into it.
Basically, I have an unattended automation that runs perfectly (locally) under Studio. When I try and run it ( remotely) under Orchestrator, it largely runs but fails a couple of steps that are image click activities (would have preferred to use proper selectors, but the controls in question were not cooperating with that). HOWEVER, if I open a Remote Desktop session to the remote machine the robot is running on, it works fine (right up until the session times out at least)

I don’t think it’s a resolution issue, although I can’t set my local computer to the same resolution as the remote one to test this.

Hey!

Welcome to community!

There could be many reasons…

  1. The speed of the robot
  2. Website loading time
  3. The Network

the only one solution is too add some delay!

We can fix this issue…

Add some delay between the activities or inside the activities

  1. Delay before
  2. Delay after
  3. Delay between keys
  4. Waif for ready - Complete

Can we check in this way

Regards,
NaNi

Thanks NaNi - I’ll take a look at that as an approach.

1 Like

Don’t log into the session then disconnect. SIGN OUT of the session completely. THEN run the Job via Orchestrator.

Just tried that, no luck, but when you say “SIGN OUT of the session completely”, what exactly do you mean, as once I disconnect I don’t have a session to sign out of. Or did you mean sign out of my (local) windows session too?

Click the Start/Windows icon, click the profile icon, and click sign out.

Don’t just close the RDP window. That leaves your session running which interferes with the automation. Orchestrator needs to start its own RDP session.

No, sorry, that’s not doing it. Thanks for the suggestion, and your patience, anyway.

You can set the Robot’s resolution in Orchestrator. Set it to the same as your local desktop. This is almost certainly your issue, as image recognition is VERY sensitive to resolution.

hello,

@Ben_Wightman i have experienced this in the past. This may be down to the version of UiPath Assistant you have installed on the VM. it sounds like you have the attended version but you need the unattended one.

Tried that, no dice sadly. That had been an issue on a previous automation we’d used, but seemingly not this one.

We have other automations that work just fine on this robot, so my gut feeling is that that’s not the issue. Thanks for the suggestion though.

There is no “attended vs unattended” Assistant. Assistant is the interface for running attended automations.

this is untrue. It depends how you install it. This is only a matter that concerns Enterprise licenses and not community

I’m sorry, that’s not how it works. Assistant is the interface for attended automations. It has nothing to do with unattended automations, because those are run by the underlying robot.exe executable. Assistant is just a front end for robot.exe to run attended automations.

I suspect you’re confusing attended and unattended licenses with Assistant.

https://docs.uipath.com/robot/v2020.4/docs/uipath-assistant

yes but when you install assistant you choose which robot.exe to install. which is why you have the following options
image

That’s about licensing and isn’t relevant to Assistant. Robot and Assistant are not the same thing.

Sorry I understand they are different things. The Screenshot I attached below is not to do with licensing it dictates what robot.exe type is installed on the machine. If it is the wrong when then it can cause issues, I have experienced this first hand in industry.

previously we experienced an issue where only activities that where tailored to run in the background would work when running with an unattended license on a virtual machine which should not be the case

Here is how I fixed that exact issue. The default Image accuracy is .8, but this does not always work in Unattended, even though it works when watching it run attended on the screen. .6 seems to work perfectly every time.

image