Timeout reached BringIntoView() BringToForeground() when using a trigger on a unattended robot

We are having some trouble with our project to run an unattended automation on a server.

If we run it with Assistent on the server it runs perfectly, if we start a process with the orchastrator or use the trigger it also runs perfectly, but when we want to try and run it unattended we get an error:

RemoteException wrapping UiPath.Core.ElementOperationException: Timeout reached. —> RemoteException wrapping System.Runtime.InteropServices.COMException: Timeout reached.
at UiPath.UiNodeClass.BringIntoView()
at UiPath.Core.UiElement.BringToForeground()
— End of inner exception stack trace —
at UiPath.Core.Activities.ObsoleteTaskAsyncCodeActivity`1.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
— End of stack trace from previous location where exception was thrown —
at UiPath.UIAutomationNext.Activities.NApplicationCard.OnFault(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

We have tried to set the LoginToConsole parameter to true or fals, but nothing works when we disconnect on the server to run it unattended.

I also tried to set the resolution of the screen but with no effect.

any idea’s?

That seems to be the issue with the resolution. please make sure the resolution you have for that system while you access and develop the robot should also be the resolution provided in the orchestrator for that robot account.

Resolution can be entered in the robot settings from orchestrator.

Hi @kws1 ,

As mentioned by @rahulsharma check your screen resolution and update screen resolution in settings.

And also check whether you are having the robot running in service mode. if you use uipath msi file to install bot you would get robot in service mode by default.
please restart your robot service and restart your VM so that it will disconnect any user sessions are there with that VM. After that try executing your process from orchestrator via un attended mode. please try and let us know. thanks.