Robot does not run, when the remote machine is disconnected, is there a solution?

for the robot to run via osquestrator on a remote machine, in case the remote machine needs to be connected in the background? I did a test here with the remote machine turned on, it’s just that when I disconnect the remote machine the robot doesn’t run. This comes up against some kind of license or is it something that needs to be “activated” in osquestrator

are you saying that the machine you want to run is turned off?

The robot will not switch on the VM, you need to schedule the start time with the help of IT. Also, if it’s a cloud VM you may have a script tu start and run it before starting the process.

The machine should be switched on to run the robot

1 Like

Thanks for the answer.

so, in this case, this machine is turned on.

I would only be logging in remotely,

for the robot to run by itself by the osquestrator, because in the robot, I put a process to run every 30 minutes for example.

the funny thing is, she even plays a role. and when the first click comes, the robot locks up.

But when I’m connected (leaving the machine in the background in this case) the robot doesn’t crash

it’s just crashing when I disconnect from the remote machine.

Ok so it locks up means break?

That might he due to the resolution issue. While robot visits the VM to login and start process, the default VM login is used and that might be the reason is failing.

As you stay connected the VM resolution is set to your system with a resolution in which you have developed the robot (i assume)

If you can adjust the VM resolution in orchestraror to the one in your machine, that would work.

Don’t do this. If you log into one of the robot hosts, LOG OUT. Don’t disconnect. Don’t just close the RDP window. Don’t lock it. LOG OUT. Then run the job.


the process goes normal, opens the browser, email, but when you click on something it breaks

yes that click failure cna be due to the resolution issue. As the opening browser and email sending takes commands and APIs respectively

Is it possible to take a screenshot in the unattended mode ay first to see what os the resolution of the screen by default?

You need to install Studio/Assistant as a service.

And then allow console login

“Logon no Console” = True ,

For this to work it is necessary to configure the unattended user

Hope this helps :grinning:

You rarely want login to console set as true. This will make it so that only one automation can run at a time on that server. Setting logon to console as true is a bad idea, and not a valid solution here.

so at first, it is not possible to run the robot on another machine remotely with it disconnected?

I thought it was some property of the click being incorrect.

but the click works when the remote machine is connected.

and it doesn’t work when it’s off

so I think the problem must be on the machine, do you agree?

I saw people talking to add the picture in picture option, but it didn’t work either.

Try selecting logon to console and make it off.

Then try re-run

Again resolution needs to be checked from orchestrator. Please check that too, that can be the reason possibly

if you say pip doesn’t work, that depends on error. But if to feel that’s related to system, you may get some help from IT team to understand the configuration for remote login

1 Like

It causes issues. You need to let UiPath establish the RDP connection and open the session.

Log into the server as the robot user account then LOG OFF. Then try the job and tell us what happens. If it still fails you may need to test Simulate Click instead of Hardware Events for the click type.