Automating a software (installed program on desktop)

uiautomation
studio

#1

Hi, I am testing whether UiPath is the right solution for my company where we use a software program that does not simply allow a data import but only time-consuming manual typings (copying & pasting, or sometimes only typing and clickings). I have tried UI Path enterprise 60 day trial version (before making a decision to buy for my company) and it seems all automation activities works pretty well for the web automation but looks like there are some known limitations as to automating an application.

I have tried to automate clicking functions on this desktop program (accounting/HR software) but not able to get any selectors - tried all scraping methods including Citrix image click. Recording function does not work at all for all recording method as well. And UiExploerer does not show anything I can use as a selector.
I guess this program itself is written in a programming language that UIPath does not support at all but I wonder if I’m not able to do this because I haven’t bought the license yet.

I would like to know whether there are specific limitations on the type of programing language/environment that UiPath cannot automate for simple desktop activities (such as click, copy & paste values from an excel, drop down selection etc).

Appreciate your support.


#2

@Mrcurios There is no limitation on trial version or license. If you buy license then you will get UiPath paid technical support.
Coming to your concern on desktop application. Could you please check your packages.

what packages you have installed. there are several packages are available. please choose right packages and try to automate your desktop application. You can reach packages from Activity panel(Ctrl+P). I am sure you will feel delight.


#3

I installed all possible packages and still didn’t work.

Jk

      1. 오후 3:08 Krishna uipath@discoursemail.com 작성:

#4

Then check out your DotNet Framework, for that try to automate on different machine and see if that works or not. if that is working then see what version of DotNet Framework is available in that machine and try to match with your machine.
Hope that will solve your issue.


#5

Thanks rKelchuei, sorry if it is too basic but would you mind where I could check DotNet Framework?

Jk

      1. 오후 3:28 Krishna uipath@discoursemail.com 작성:

#6

In your machine Start menu–> control Panel --> click on Programs and features. you will see list of programs installed for your computer


#7

Hi,

Could you share what application that is, or at least what technology it was made with?
There might be workarounds or solutions to it (f.e. for Jinitiator it’s here).

Even if there aren’t, it would be valuable information to know what it doesn’t work with - either for further development or at least knowledge of what to avoid.

It’s interesting though that it doesn’t work with Citrix-type activities.


#8

Are you available for a remote support session sometime next week? We may take a look to better understand your issues.

Thanks,
Adrian.


#9

what software?
… or try this Field Control cannot be read when the XAML is moved to another PC and make sure you’re running UiPath and the IE app with the same elevation rights (both admin or user mode)


#10

Yes that’d be very nice. I can have a session on Tuesday or Wednesday - please send an email to me please so we can schedule.

Jk

      1. 오후 8:13 Adrian Dorache uipath@discoursemail.com 작성:

#11

The application is an accounting software similar to quickbook in the US but developed in Korea, more than half of all businesses in Korea use for bookkeeping, payroll, and tax filings and other suite of business administration needs.
I am not very familar with the programming basics so not sure what technology details I should know about this application - can you tell me in more detail what i should find out from the developer?

Jk

      1. 오후 7:45 Andrzej Knioła uipath@discoursemail.com 작성:

#12

Hi Badita, the elevation right was the key to solve the issue! The program is recognized once I run both UI Path and the program with the same right.
Thank you.