UI Elements not found by UiPath


#1

I’m having trouble automating a workflow for one specific program. When instructing UiPath to for example click on a UI element, the element is highlight with a blue box like usual, but after clicking it nothing is added to the workflow. No UI interaction is registered in UiPath.
I even tried using the Citrix Recorder, but does not register any click done on this particular program. The recorder works on the desktop area and all other programs. The only way I have found to make it work is to run the program on a remotely controlled computer, and use Citrix recording on TeamViewer.
It seems like this program somehow hides the necessary information from the OS.

Has anyone encountered something like this before? Is there a better workaround or fix?

I can’t share any information about the program except for that it’s old and written in the C programming language.

Studio Version: 2017.1.6435 Community Edition

OS Version: Windows 10 Enterprise 64-bit


#2

You can use Citrix recorder on local applications as well, just FYI.

But the behaviour does seem weird.
If you indicate this applications window in below workflow, does it print anything?

Warning if it does pick up all elements, please be prepared for your Studio to hang for some time as it will print all selectors for all elements.

If you want to check just a couple at first, modify the loop to be:
Foreach element in allElements.Take(10)

BecauseWhyNot.xaml (6.5 KB)


#3

I did use Citrix recorder locally, as I tried to explain. But when Itry to register a click, I don’t get the usual message box asking where in the field to click, and UiPath doesn’t save any clicks. It’s like the window doesn’t exist.

No elements are found. I learned just now that other people I’m working with have even tried using MS Spy++ to try to identify the elements, but to no avail.

I can somehow understand that it might be possible for an app to not show any UI elements to the OS, but the fact that not even image recognition through the Citrix recorder can pick up anything is beyond me.


#4

Sorry, I didn’t pick up the extent of what you already tried initially. It’s usually safer to be sceptic with new users but you really did go above and beyond before posting.

Tough one.

Best course of action I could recommend is to contact support. As an enterprise user you should already have an NDA/confidentiality agreement so they could help you directly and try different ways.

@qateam


#5

Okay, thank you for your suggestions!


#6

What happens if you manually add the actions and indicate on screen…

  • click image
  • type

Could you paste a UI Explorer Snapshot when indicating elements on that app?

How does the screen scrape workers with native/OCR?


#7

Hello,

This could happen if the application that you are trying to automate is running elevated or with High integrity (usually Windows system windows run as High integrity Eg: Event viewer, Services, etc)
You could check this from Task manager or Process Explorer app. In the bellow screenshot you see 2 Notepad processes. For the one that has Elevated = Yes it happens the same thing that you are facing.
As a workaround you could try to start UiStudio as admin, but this will not guarantee that you will be able to automate your app.

Thanks,
Cosmin


#8

Any workaround for Unattended robots?


#9

Have you tried doing the automation on a different machine? maybe something’s wrong with that Studio installation.

Hmm, the Citrix recorder doesn’t have anything to do with the type of app, so it kinda HAS to work :slight_smile:
Can you do a ClickImage on a button in your app and let us know if it works? And post a screenshot of this simple workflow too.


#10

@cosmin.sandulescu Seems to be onto something. I tried doing automation on Event viewer, and the behavior is the same. Just doesnt’ work. Starting UiStudio as admin doesn’t have fix the problem still though.

I think the program was made with security in mind. It handles sensitive data, and the makers of the program were negative towards our wish to automate it.

@Cosin The Citrix recorder does actually do have something to do with the app if run locally. It can identify text fields and buttons for some of the methods, and then it tries to identify selectors. When using Click Image nothing happens after selecting an area. You can try it yourself on Event Viewer. Let me know if you can make it work.

Thanks everyone for your ideas and suggestions :slight_smile:
We are implementing this automation for a customer, and my colleague has already almost finished automating it in a virtual environment, so I think we’ll settle with this.


#11

Can you collect some traces? as explained here https://robot.uipath.com/v2017.1/docs/enabling-low-level-tracing
Collect traces when running UiPath studio as admin and non-admin.

Thanks,
Adrian.


#12

Any idea on how to determine if a file exists in the remote environment?


#13

Hi,
We are facing a similar situation when an application is run with higher elevation using “local admin” rights. When UiPath runs as administrator, it generates selectors but still fails each time workflow is run. Is there a known solution to this? The only way to run the application is using “local admin”. This could really make an impact if our client chooses UiPath Enterprise version or not. Any advise would be helpful.

Thanks & Regards!


#14

Hello Ankur,

thank you for your inquiry.

Ankur, can you please paste here the selector you are using in order to help you out. I’m thinking that there is something that changes on the selector.

regards


#15

Thanks Beesheep for your response. I have confirmed that it’s not a selector issue. There are no parts of the selector which are changing. It’s failing for all the activities in the workflow which interact with this application which runs with higher elevated rights. As discussed earlier in this thread, it’s definitely related to the fact that UiPath is not able to inject in the application as it’s run with higher elevated rights but i was hoping it will be fixed once we run UiPath as administrator.