Audio devices via RDP

When logging in to a normal RDP session there is an option to set “Play sound on the remote PC”. Is there a way to force this setting when a robot logs in via an Orchestrator scheduled job?

Welcome to uipath community
You mean like you want to neglect this option with a click while logging in
Kindly elaborate a bit more in this pls
Cheers @kborg

Hey Ken,

You may be able to save that setting to an RDP file and then use that to open the connection. You’d just then have to have your process use that file instead.

Ok. I’m not a developer, I’m asking for the developer. Is there actually an option when building the process in UiPath studio to specify an RDP connection file?

Hello Ken,

No worries regarding you not being a developer. The Remote Desktop Connection application can create what are called RDP files that specify a saved connection and its settings. It has a command line interface command to run the program and you can give it one of those files via the mstsc command.

To actually run the program, you can use Open Application, Start Process, or Invoke Power Shell depending on your needs.

I hope that helps

Oh I know how RDP works. And we’re not using a separate RDP connection within the UiPath process. I’m talking about when an unattended robot is triggered, we need to modify the RDP connection that it uses to connect to that robot machine.

As far as I know, when you play a sound on a bot pc, it is played by the bot pc’s default sound device. Is that not what you’re finding?

Our bot PCs are vms. We’re seeing that the audio is in “passthrough” mode, meaning it wants to play on the computer that is connecting to it. It needs to be in “remote” mode:

Hi @loginerror,

Hope you can help us regarding this, any idea how to do this? Thanks!

Hi @kborg, were you able to find a solution for this? Thanks

There was no way to do this in an Hyper-V environment. We had to move it to a VMWare environment and we were able to add an audio device to the VM.