Audio settings of RDP session of BOT in VM

Hi,

How can I force Audio settings of RDP to “Play on remote computer” (see image below) when a Robot logs in via Orchestrator? By default, robot logs in to RDP with “Play on this computer” set.

Hello @mnlatam!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

Hi @mnlatam

Although I am not sure if it is possible to set it from Orchestrator, you could most likely change this setting by executing some PowerShell command as part of your process.

1 Like

Hi @loginerror. Thanks for your input.

Correct me if I’m wrong, but isn’t once we trigger a job from Orchestrator to run in a VM, first thing bot will do is it will login to VM via RDP? How does bot login to VM? Our VM admin already changed the default to “Play audio on remote computer” but it still fails to launch an app due to no audio driver was not found. My process works fine when I run it attended with “Play on audio remote compute” selected.

One idea that comes to mind is whether the robot is set to not login to console (Login To Console = No), see here:

It should be the default setting though.

Yes we made sure that Login to console is set to No. My concern is how can we modify the RDP settings that the bot uses to login to VMs when we run from Orchestrator unattended? The requirement is that the audio should be played on remote computer instead of local. When I run attended, I manually select “Play on remote computer” in RDP window when logging in to VM and bot works fine. I am not sure on how unattended bot will consider that.

Could you still clarify what is the purpose of playing the sound on a machine

The application we are automating requires that the sound is played in VM when it is launched. It is a VoIP application that calls a hotline and captures the audio output and converts it into text.

We were able to solve this by setting the Login to Console = Yes.

1 Like