Attach window cannot find UI element

I am trying to automate a desktop app. When I use desktop recording to make the first clicks, I can select the elements just fine. When it attempts to run, it cannot even find the window to attach to. Nothing changes from the time I use the recorder to running the process.

When I go into “Selector Editor” the element is validated and when I click to highlight it highlights the window perfectly. I have tried every combination of selected and unselected options that are available in the UI Explorer. Is there anything else I am missing that could cause this error?


kindly elaborate this pls

Please provide at least a screenshot of the resulted recordings activities with their selectors…

Hello @steve3424,

Did you look into this point ?

They went through a lot of different issues

1 Like

Sorry, my initial post was a bit rushed. I will try and clarify here.

I am running Studio Community Edition 2019.9.2 on a Windows 7 Professional machine. I am trying to automate a workflow on a desktop app. I am using the desktop recorder to make clicks in the app. In order for the recorder to work, I am running UiStudio as admin.

The recorder can record my workflow just fine and validate my selectors. When I run the process, the Attach Window activity fails with the error “Cannot find the UI element corresponding to this selector:”

My question is: If I can use the recorder to find the window and record a workflow, why can’t it attach when I try and run the process?

I uninstalling and reinstalling, I tried using different combinations of selector attributes to find the window, and I tried using basic recording as well. I will attach an image of the desktop recording.

I did not find that. I will go through and try their solutions. Thanks!

Hi @steve3424

hello check the selector through the UiExplorer

@shwin S

if it only works right after you record and after will not, then there is something in your selectors that are always changing… you need to notice those parts and make them dynamic, usually using a * will do the trick…

I have checked in there. I have used every different combination of attributes to identify the selector. Is there something else I can try within UI explorer?

I don’t see how that is possible because the window is completely static. I will try making it dynamic. Is that done in the UI explorer?

use aaname

ashwin S

Every activity will take the from the application a certain selector and although visually may be always the same, internally it may not… it can be seen in the activities or using the explorer (more advanced), your screenshot im afraid did not show any selectors…

Thank you for the replies on this thread. I was trying not to divulge too much information for security reasons. I was able to work around the issue simply by running the target application as user instead of admin. The problem arises when any target application is running as admin privileges, but once they are run as user it works fine. I thought simply running UiPath Studio as admin should allow access, but it isn’t working. So although I didn’t fix the issue I no longer have the problem.

1 Like