Assistant does not start on Windows 10 with Community Edition 2023.2.0-beta11986

After the Community Edition upgraded my studio from 2022.12 to 2023.2.0-beta.11986, Assistant fails to startup. The error I see in event viewer is

UiPath.Service.UserHost 23.2.0.0
TraceError: D:\a\1\s\Robot\UiPath.Service\UserServices\AgentOperations.cs:UpdateProcesses:161
: System.AggregateException: One or more errors occurred. (Object reference not set to an instance of an object.)
—> System.NullReferenceException: Object reference not set to an instance of an object.
at UiPath.Service.UserHost.AgentOperations.<>c__DisplayClass13_0.<g__AutoInstall|4>d.MoveNext()
— End of inner exception stack trace —, HResult -2146233088

Studio itself works fine. I’ve tried multiple re-installations and have cleared out AppData\UiPath folders as well as .nuget but nothing has fixed the issue.

Details of my installation:
Studio 2023.2.0-beta.11986 - 2/27/2023
Community License
User-mode Installation
License Provider: Orchestrator
Activation ID:
Microsoft Windows 10 Pro 64-bit
6.0.7

1 Like

Hi @TaKoNoMeaT
please check these two threads.

2 Likes

Thanks @raja.arslankhan this helped.

I tried running the command and the process spit out that the 1337 port was not available to connect to as a another application was listening on it.

After killing the other process I was able to launch assistant.

I think UiPath needs to fix its port usage to listen on a higher numbered port to not conflict with other apps.

@TaKoNoMeaT
Welcome. Yes this issue already addressed and hopefully UiPath will fix it soon. Happy automation.

Same problem here only I am trying to set up 2 users on a single VM.
Once ONE Assistant is running the other user is blocked because port 1337 is already in use.

Win Server 2016

Hello,

Thanks for raising this issue. We will fix it in the next releases.

Best regards,
Elena

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.