UiPath Assistant not launching in ec2 instance


I am an uipath learner and installed UiPath community version in Amazon ec2 instance. When I tried to launch UiPath assistant nothing happens. The UiPath assistant is not launching at all.

I tried to re-install Uipath several times, but it din’t help. I can see the following processes are running in the task manager. But I couldn’t find the root cause of this problem.


Since this is brand new ec2 instance, I believe some pre-requiste softwares are missing. Latest version of .net framework is installed. Not sure whether something else needs to be installed.

This works perfectly in my personal computer.

Any help on this issue would be much appreciated!


Hello All,

I have figured out the solution myself. The following steps worked for me. Hope this helps!

Step 1: Navigate to the Target Path of UiPath assistant. Right click on the UiPath.Assistant.exe file and click on Troubleshoot compatibility.


Step 2: Now click on “Try recommended settings” option.

Step 3: Windows will identify the corresponding compatible settings automatically and asks you to verify. Then Click on “Test Program”

Step 4: Check whether UiPath Assistant is opening now.

Step 5: If the UiPath assistant is launched successfully, then click on “Yes, Save the setting for the program” option.

Step 6: Windows will apply the relevant settings to the program. Now click on “close” and try launching UiPath.Assistant from Start Menu or Shortcuts.

Happy Learning!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.