Assignment 1: Transaction 1 is repeted and it doesn't go to the 2nd transaction

Hello Everyone,

I have been on this assignment since quite a few days and have been able to solve a lot of issues and seems like I am stuck at this last problem.

Transaction 1 keeps on going and it doesn’t move to the 2nd transaction. I tried changing a few things, it either keeps on repeating transaction 1 or it just stops in 1 transaction.

I have added comment out activity in the set transaction status but to no use.
Attaching the file.

Please help.
Thank You. (1.7 MB)

did you implement a counter increment?

In what workflow are you talking about? and at which step?

Is it in the set transaction status workflow? yes, there is an increment step in it.

I had a look at your process.

  1. I do not see any xaml related to the application you are automating.
  2. Your process.xaml and other xamls are basic REFramework code

Have your made the changes as per the assignment?
The project does not go into next transaction as there are no transactions that are being processed in your automation.

Yes, their is an increment of TransactionNumber in the setTransactionStatus.xaml file.

All the Xaml related files are in the practice 2 folder>system1 or SHA1Online folder.
I have made all the changes as per the assignment except that I am not using the config file for anything.

The project runs successfully. It runs the transaction 1 continuously without going to the 2nd one.

Please share your latest zip as the one you shared above isnt correct.

Here you go,

ReFramework_UiDemo (2).zip (1.8 MB)

Issues that i see

  1. in Initialization arguments mapping
  2. in GetTransactionData in_TransactionNumber either shuould be 0 or in assign of out_TransactionItem use (in_TransactionNumber -1) so that you get the 1st item in the array as currently its strating from (1) index which is 2nd item in array
  3. in System1_NavigateTo_WIDetails out argument mapping WorkItemID is no mapped
  4. in System1_ExtractClientInformation need to add trim on Country variable to obtain correct value
  5. Process.xaml out argument mapping is missing

Formula is not assigned

6 You have invoked System1_ExtractClientInformation again in SHA1Hashcoceonline.xaml where the mapping is done
7. Add a close button on the pop-up in the update work item.xaml
8. You do not need a log out in the middle of the process, nor is the System1 invoke is required to be added . This is done only once through out the process. (you are creating multiple browser instance)
Also you cannot use ope browser here, rather attach browser

8. Use Simulate type and click where possible to make your process run without holding the i/o

Finally coming to your process next transaction. Well it is processing the next item but since you have hard coded 1 in the log message it has created a confusion for you.

Hope this helps.

1 Like

Thanks Nadim. That is quite a thorough evaluation. This is what I needed. I am able to solve mostly all of the issues except the No. 3 - in System1_NavigateTo_WIDetails out argument mapping WorkItemID is no mapped

I tried logging a message with work item id in the transaction data workflow, It is taking client details from the same workitem.
One thing which worked was changing of transaction numbers, which is good.

Any suggestions on the back traceability of work item ID?

1 Like

For #3 you can ignore as it was a code correction suggestion.
If you want to log your WIID you can do it by updating the value here from TransactionItem to TransactionID
TransactionItem is anyway a DataRow which will not get logged as a string so this will not work.

No I mean, How do i make sure that every time a new work item ID is picked up and then it lands up on that work item details page?
the process transaction is picking up a new transaction everytime as per the transaction number but, it is taking the same work item id and details again and again.

As per the code that you shared earlier it was working just fine. It was picking the next one in the array.
Have you made any changes in the process?

Please share so that i can have a look.

Apart from changing the in_Transactionnumber to 0, nothing more.

The other code suggestions, I would be changing once my main code is good.
ReFramework_UiDemo (1.8 MB)

1 Like

well your issue is here. You have hardoded the number to 0 when mapping the argument. Use the variable TransactionNumber and it will work as expected.

thanks Nadim.
Everything is working just fine. I am still getting a 0/100 after i submit the assignment.
Can you please check?

ReFramework_UiDemo (4).zip (1.8 MB)

1 Like

The issue as i highlighted earlier, failure is maybe due to the space in the hashcode formula.
Please verify that

I made the changes already and that problem is solved. Last problem which arises is, the transaction fails once all the transactions are done.
In the equation,

when in_transaction Number starts from 0 and in_WIList has 8 counts, then all transactions go through but, it stops after no.7 as it starts from 0 and not from 1.

What can we do here to make sure it passes.

update the equation to make it just < less than and not equal

I had already tried that.
The issue was I was running it in the debug mode and when I ran it on a normal mode then I submitted.

I passed. Thanks for your help.
Onto the next one. !!

1 Like