Advanced Training assignment 1 - how to get transactions to iterate?

I’ve read at least 10 forum posts and I get different answers about this so I have to ask the experts :).

Does the ReFramework automatically iterate over the transactions (i.e., add +1 to TransactionNumber) or do I need to use Assign and do it manually?

In the PDF assignment it says to delete all 3 activities in the SetTransactionStatus.xaml file. If i delete them then how does it add 1 to the TransactionNumber?

Confused for days on this assignment. Thanks in advance for any help.


Hi @timeich23 ,

Not an expert, just provide my understanding…

Question 1:
Does the ReFramework automatically iterate over the transactions (i.e., add +1 to TransactionNumber) or do I need to use Assign and do it manually?

Yes, ReFramework automatically iterates the transactions and you don’t need to do that manually. The +1 to TransactionNumber happens in SetTransactionStatus.xaml flie. Each part of sequence ‘Success’ and ‘Handle Business Rule Exception’ has assign action shown as :


Question 2:
In the PDF assignment it says to delete all 3 activities in the SetTransactionStatus.xaml file. If i delete them then how does it add 1 to the TransactionNumber?

PDF says:

In my understanding,we only need to delete the part of “If TransactionItem is a QueueItem” or “Set transaction status” activity and keep all other things because this assignment doesn’t need to use the queue got from Orchestrator. This delete action has no effect of TransactionNumber‘s iteration.



Ok, I’ve already done that and my transactions keep repeating “Transaction 1 Processing”. I may be missing an argument or variable but I’ve tried a mix of all the forum posts and can’t seem to get it to work. I can run the full project but it just keeps going on Transaction 1.

I have also seen the value of TransactionNumber in the Main.xaml said to be 0 and also 1. Does that make a difference as the Default value?

Thanks! I am really putting in a lot of time on this and seeming to hit roadblock after roadblock after closely following the assignment in the PDF.

Hi ,

I suggest you to use debug to trace your program issue, that may be a quick way to find the issue by watching the variables data change and the project execution steps.

And for your question, I used TransactionNumber with default value 1. Also you can check the “in_WIList.Count” first in GetTransactionData.xaml, make sure your transaction source data is correct (should greater than 1):


1 Like

I’ve been doing the debug for a couple days. I’ve read numerous posts about how to set arguments in and out but the part where you posted the screenshot always stays at Processing Transaction 1, then goes through the steps but doesn’t increment. I’ve read to add an "Assign - TransactionNumber - TransactionNumber +1 but also that the ReFramework should take care of it. Confused which is correct. Thanks.

I’ve been debugging and I can verify that I’m seeing 12 values in the In_WIList argument being passed to GetTransactionData so that is good (I think). Here is a screenshot of Studio while I am debugging:

Popup message box shows 12 as the value of in_WIList.Count.toString: image

Here is the IF more items sequence: image

Question: Should I be reducing the in transaction number by 1 like this?: (in_TransactionNumber -1)

Thanks so much for any help. I am so close but have been blocked for a few days. When I change an argument or value it fixes one thing but leads to another :slight_smile:

Also, here is my out_TransactionID value I assign after the IF more items sequence. image

Appreciate the help! Thanks!



I think you should focus on the TransactionNumber, debug it step by step, in Process Transaction – SetTransactionStatus.xaml, you will see which part executed: “Success”, “Handle Business Rule Exception” or “Handle System Error”, then step into the specific part, to see the io_TransactionNumber+1 works or not.


I have been debugging step by step all day and fixed a few things. I am really confused by the directions in the assignment. It says to delete the 3 activities in SetTransactionStatus.xaml. Is that wrong? If so we should get that corrected as it caused me hours headache. Thanks!


For me, I did the following actions to “delete the 3 activities in SetTransactionStatus.xaml” description:

  1. Success sequence: Comment “If TransactionItem is a QueueItem” sequence.
  2. Handle Business Rule Exception sequence: Comment “If TransactionItem is a QueueItem” sequence.
  3. Handle System Error sequence: Comment “If TransactionItem is a QueueItem” sequence.


Okay, thanks! I did that and I am getting the WIList passed now. I’m running into a weird error that causes the Process.xaml to fail and basically closes the process down.

Error message from the Output pannel (in red):
Invoke System1_NavigateTo_WIDetails workflow: The given key was not present in the dictionary.

Is there a way to tell which “given key” is causing the error?

Thanks in advance!


I fixed the issue somehow. I’m all the way to the System1_Update_WorkItems.xaml but have spent hours already and can’t get the attach browser to work to update the work items with the hash code and status to “completed”.

I’ve read through the forums and the solutions seem to be all related to Chrome. Do I need to switch from IE to Chrome to get it to work?

I am using Selectors and it shows Validated in the Selector Editor
<wnd app='iexplore.exe' cls='IEFrame' idx='1' title='ACME System 1 - Work Items - Internet Explorer' />

Any ideas? Also, should I open another post since this is a different issue than my initial one?



I was just able to get this to work. I added a separate Attach Browser to the original Work Items page to click the “Update Work Item” button. That opens up the popup browser and I do another Attach Browser activity.

I use this and it is working for IE:
<html htmlwindowname='WI-Update' title='ACME System 1 - Work Items' />

Cool !

A small suggestion, sometimes you can use wildcard-characters in selector, it will solve a lot of issues.


I have been using this one for every other browser attach it works great:
<html title='ACME System 1 - *' />

For whatever reason the Attach Browser to the popup window browser was way different.

@timeich23 did you solved your problem? I will be appreciate for any help