Arguments - Invoke Workflow file Not Working

Hi,

I am trying to recreate the example of using an argument from the resource section. I have followed the steps all the way to adding a message box to display the value of the argument.

When I run the robot the message box doesn’t display. The output, however, shows the value of the argument from the first sequence but not the second sequence.

I even downloaded the project file from the tutorials but still no luck.

What am I adoing wrong?

Hi
Is the arguments passed with proper IN and OUT direction
Like if we want to pass a argument with a value then use IN argument
Or
If we want to get the value from a argument then use OUT direction so that it can be used outside the project

Moreover to import the arguments from invoke workflow file activity we will be clicking on IMPORT ARGUMENTS option
And that would import all the arguments created in that xaml which is been invoked
And to use those arguments with OUT direction we will be mentioning the global variables created in the main xaml as values to them in ARGUMENTS Property in the property panel of INVOKE WORKFLOW FILE ACTIVITY
Here the thing is once after importing and assign the variables with arguments property don’t click on the IMPORT arguments option again
Because it will freshly import the arguments again and that would not have any value in it
Unless we are creating a new argument and if we want that to be included in INVOKE WORKFLOW ACTIVITY don’t click of import argument

And similarly once after importing and assign arguments with variables save the xaml once

Cheers @Paakay

@Palaniyappan thanks for the quick response.

I have done everything outlined in the tutorial. I the direction section, I used In/Out and created a variable in the second sequence to assign the value of the argument to.

The trouble is the message box is not displaying when I run the robot. I don’t get any output from the second sequence either.

@Palaniyappan

Below are the screenshots for my workflow and output.

Hi
I hope if we run the Another process xaml it would have shown you the message box
As I can see in the last image and it has the output value in the output panel from Writeline activity

Cheers @Paakay

Thanks, @Palaniyappan

I was hoping same. I don’t know why the dialog box is not showing. The value for the variable in the Another process xaml file is not showing in the output panel. That tells me the Another process xaml file is not running.

I have tried looking everywhere for an answer but no luck.

But this image has the value in output panel


Cheers @Paakay

@Paakay
The workflow execution starts with the “Main.xaml”.
I think you are trying to Invoke the Main.xaml from the Anothe rProcess.xaml.
Please can you set Another Process as Set As Main (right click on Another Process.xaml from the Projects tab and “Set as Main” and try running AnotherProcess again.

3 Likes

Awesome @Palaniyappan

Works like a charm but why? I thought we were passing in the global variable from the Main.xaml file to Another process.xaml file? A little hard to reason about how it works the other way around.

I was thinking in terms of how modules work in JavaScript.

Thanks a lot for your time and effort.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.