Anchor Base activity getting timed out


I was trying out the Anchor Base activity for the first time and could not get it to work.

The steps to perform can be summarized as follows. In an opened Notepad window, enter some text, click the Format menu and change the font size to 16. I used the desktop recorder to capture the above steps. However, when the workflow file is executed, it got timed out on the menu (Format) clicking step.

The runtime error message and the configuration concerned are as follows.

When I did not use the anchor base, the solution would work. Any idea what went wrong?




Welcome to the UIpath Community.

Please find the below thread and download that example to learn more about Anchor Base Activity.

Hi @lakshman,

Thanks. I did that already. That example worked but I was wondering why the Notepad example I tried didn’t work.

Best regards,

1 Like


It’s looks like you indicated same element in both Activities.

And also you put the elements one after the other inside Anchor Base Activity. Could you please show me the screenshot of Anchor Base Activity properties once.

These were straight from the desktop recorder though. Anyway, the properties of the Anchor Base activity are as follows.

Since you mentioned the Anchor Base activity properties, I tried changing the AnchorPosition from Top to Auto, didn’t work, but started to work after I changed it to OnTop!

Any idea why?

Many thanks.

See below with the AnchorPosition option which worked.