Selector working sometimes

I created a simple flow in UI Path Studio 2019.12.0-beta6.1, to log to an ERP. I tested it many times and it worked correctyly. After a week or two I went back to my flow and it failed to run. It failed to run, problem concerning the first UI operation (entering a password) appeared. I changed selectors, created activities from a scratch, restarted my computer (Win 10), changed version of UI Studio from preview to stable. Sometimes it works, sometimes not. I can’t find a rule. Please, find attached screen and xaml. I would appreciate any advice, how to diagnose, to fix it, finally to workaround.

if you replace the anchor activity, with a type into or set text activity what happens?

Hi Fernando!
Originally it was “type into”, I changed it to “anchor base” in hope to improve its stability. It didn’t helped. It’s strange that despite the error, the selector is validated in its Editor.

Have you tried using the Repair button on the Edit selector window?

1 Like

Hi jcvsalinas!
Repair button is disabled, probably due to positive validation. As shown on uploaded picture :slight_smile: