Do you want to use an Anchor?


I am learning recording from the first tutorial. It’s very basic one. From the notepad file clicking format menu and changing the text font. Whenever I click Format menu (attached) this pops up. I tried saying yes and don’t show me the message or indicate anchor. I can’t get rid of it. That’s might be the reason when I run the record it goes well till it hits the format. Then I got this error

I can’t add the second picture because I am a new user? Why punishing new users…

1 Like

This is the error I got. I hope someone knows the answer.

Thank you

Did you refer this link? There is a sample download link at the bottom of page which might be helpful for you.

That’s good one too. Thank you.

If I can’t get rid off this pop up I don’t think my recorder will be run properly. I have to click pop up select one of the options and click don’t show this message again .And it’s not part of my test. Every time I run recorder it pops up. That’s my question.

1 Like

AS the error message is itself teling “Activity timeout”. Every activity has it’s timeout property and if it is not assigned then default timeout for every activity in uipath is 30 seconds.

In your case “Click activity”: is not able to identify the “Format” option. the most probably reason is it’s selectors are not reliable or may be at the time of click activity execution the format option is not visible so activity is taking time to wait for it to appear.

If you are asking about that “Anchor pop up” then it is just for your help if you are working with such a scenario where selectors are not much reliable and dynamic then you can use this activity or feature to identify element in a more reliable manner.

For me testing sequence is working as expected.


Thank you Aksh. I think this point I will use without Anchor.


Hey Ruki

Yes you can and without anchor also it will work.

Let me know if you will face any issue with this or will need some sample ?


Hi Aksh,
Could you help me sort the same problem out, please?
I have searched the problem out among the topics and tried what has been said …
but cannot solve it

Hi All, I am faced with the same issue when performing the same recording. I simply can’t get past this issue “Do you want to use an anchor?” I am following up with the essential training and I can’t understand what is that I am missing. Can anyone please help?

I have the same error, I’m following the training, but I receive the anchor error, and the robot doesn’t click in the format tab also if I use the Anchor option.

Happens to me too. It only happens while using Remote Access on a windows instance. There I use Version 2018.1.2.

If I do it on my desktop, the anchor questions don’t pop up. Also, the version is 2016.2.6232.

So basically, the older Version works better for me right now.

Hi Akshay

I went through what you mentioned but still i coudn’t figure out how shall i remove that anchor pop-up. I just started learning uipath studio and facing the issue while automating the anyteller application. I went through the PDF video which you have mentioned in other post but since i just started with uipath learning, its difficult for me to proceed further.


Same here… Annoying, Repetitious…


Same error here! can’t continue on the Desktop and BASIC recording due this problem

I don’t understand why we can’t get clear answers to these questions. It’s ridiculous that this tutorial exclaims no programming knowledge is required yet half the time we are writing in VB expressions with no further explanation.

That aside, it is extremely frustrating, I’ve been trying to troubleshoot for two hours and I can’t get the program to just click file and save as.

Hopefully someone with useful information can help out.


Even I face the similar issue. I gave No for anchor . It executed with no errors but font is not changing as mentioned in the activity. Please help on it.

Hello kyre,

I solved it. I had the same problem but I guess it’s not a bug. When the anchor pop-up comes out, click No and don’t move the cursor. You’ll see that the dropdown list will be appeared in a bit. Probably you’re moving your cursor after clicking no, the dropdown list disappears and you can’t see it.


Hi Aksh,

I am learning Uipath Level 1 Developer Foundation.

Instead of selecting ‘No’ in a Anchor activity for the workflow to run. Also help to use it with using the Anchor activity i,.e.,
How to find a reliable selector and edit selector yourself or use UiExplorer and get a reliable and good selector ? Please reply asap

I had similar problem while using Azure with RDP connection. After click “no” few times (3-5) and it seemed to work with the simulator. Definitely an expected “feature” but glad able to get over with it.

Also per the tutorial, the “font” was an attribute in the step but not on the latest version. I had to change the VB expression to change the font which is not a big deal.

many people has the same problem but still no a clear solution.

anybody has an idea about fixing this problem?