Advanced Training(Academy 2) Practice 1 (UiDemo) InitAllApplications xaml help

I’m in need of help as I’m stuck in the middle of assignment 1 in Academy 2 (UiDemo Walkthrough)

When I run the InitAllApplications xaml I am getting this error:

The file path in the open application activity is set to:

in_Config(“UiDemoPath”).ToString

and I have an Orchestrator text asset set to the same name: “UiDemoPath” with the value set to the file path on my local computer stored and set to the same name in config file.

What am I doing wrong? How is the InitAllApplications workflow supposed to work?

Attached is my workflow.

InitAllApplications.xaml (7.3 KB)

3 Likes

Hi @DGold195,

There nothing wrong in the workflow as such. Were did you add the UiDemoPath ? Note that it has to be added in the Assets Sheet in Config.xlsx file.

Do let me know if this helps. :slight_smile:

Regards,
Nithin Prabhu

Hi,

I’m having the same issue here. Should I put the actual file path on the description field or do I have to place it somewhere else? Also, should we import the variable from Login.xaml to the invoke activity of InitAllApp?

thank you.

Hello,
I want use UiDemo (advanced outline1). I execute InitAllSettings.xaml it is unable to read inside config.xlsx with write line fuctions I see that all row().tostring are null. I extract data from this file with VBA and Java J2EE without problem.

  • I check with writing sheet names only null returns
  • I check with value name only null returns
    I don’t know how to fix it.
    Sincerely

I just solve this problem, now InitAllSetting (I’m not sure) and InitAllApplication are working…

UiDemo don’t work, it is too long make workable. I begin the next exercise…
For html screen scraping I have many messages ‘Attribut not supported by UiCurrent node’. When it works I’can’t filter data. Can I take this data without scraping?

you directly use data scraping screen scraping is not at all required and from the datatable generated from data scraping we can filter the data

Hello,
Thanks, so first I scrape all data from the page inside a table and after I filter it.
I see a mydataTable.select() method to filter rows.

@Divyashreem

Tanks for your help.
I extract data from html page to a input table. Afer I select some data inside a System.Data.DataRow and cast it by C# to a output table.
all tables are put on Excel files so see data.

1 Like

Hi, so I’m having the same problem. I have in_Config(“UiDemoPath”).ToString in File Name of Open application. In the Config file (Assets sheet) I have Name: UiDemoPath Asset: UiDemoPath. In connected Orchestrator, in the Assets I have an Asset named UiDemoPath (Text) Value: my path (which is correct). So where is the problem? Thanks.

1 Like

Hello guys.

In Orchestrator the UiDemoPath was in quotes and that was the problem.
I removed quotes and after that the UiDemo runs correctly.

Best regards,
Kamil

2 Likes

Check also your Arguments and Variables related to UiDemo Path and config file :wink:

Thanks

As i have not used Quotes, but still i am facing with same problem

i am still facing the same issue

1 Like

I’m facing the same issue as @manju1992 and @DGold195.

Hello Manju,

Since I have not had a look at the workflow you have built, I will not be able to give you a definitive answer.But, I would recommend you check the following:

  1. Ensure your Robot is connected to Orchestrator. In the Robot Setting window must show the Status as Connected, licensed
    Robot%20Status

  2. Pass the following arguments to InitAllSettings.xaml (Yes, the default arguments will do their job if you have not altered anything.But, just to be sure). Also ensure you pass the Config (Global Variable) as input argument to InitAllApplications.xaml

  3. Ensure you keep the Assets of type Credential in the Settings sheet of Config.xlsx & all the single valued assets (Bool,Integer & Text) in Assets Sheet.

  4. Create the asset in Orchestrator and if it’s a Path to a file/application which is not within the project folder, then ensure you place the full path without any quotes.

  5. Refer the following diagram if you have any confusion about how to use in_Config("").ToString in the workflow or what to name the Orchestrator Asset
    Config%20Cheat

Kudos :slight_smile: Hope this helps !

Regards,
Nithin Prabhu

1 Like

Hello @kresimirpa,

Check this out: Link to my Post

Kudos :slight_smile:

Regards,
Nithin Prabhu

@manju1992 , @kresimirpa

did you solve this problem? I will be grateful for any help.

I check in InitAll Settings and _Test file that it returns me good path from orchestrator.

Hi,

I am also facing same problem.

I have set all values correctly as mentioned in PDF and also in you post.
I have cross checked all the steps you mentioned, but I am still facing this problem.

I tried to find solution of this problem, I notice many people have posted this problem and the problem is not concluded in any of those post.

Please help.

Hello,

This worked for me:

2 Likes