Aaname vs aria-role

I am creating a workflow within Studio as part of the RPA Academy and I am at the stage of using the “Selector Editor” to make the selector generic so it always returns the current time.

In the academy video we are asked to edit the <webctrl aaname=‘21:22’ to aaname=’*:??’

The issue I have, is that within my “Edit Selector” I have aria-role ‘heading’ instead and entering the above wildcard digits do not get validated.

Can anybody assist?

If you see a different definition in your selector, it is likely that you have scanned a different component. (e.g. A container which houses the component you’re trying to scan)
A couple of things you could try:

  1. Try scanning the element again a couple of times, see if you can notice more than one blue booxes around the element (that might explain the different selectors)
  2. Try using ‘UiExplorer’ to see if you can select ‘aaname’ from the properties pane. It may not show up by default in your selector window. Check out forum posts on how to use ‘UiExplorer’
  3. Post screenshots with your next reply so that we can discuss specifics.

Let us know how you go.
Cheers.

Hi guys!
I facing same issues than nathan.lowe. In the “Edit Selector” doesn´t show up instead that it shows <webctrl aria-role=‘heading’ . I have tried scanning againg a couple of times and it seems doesn´t work, I´ll try with second option. Attaching screenshots from tutorial and Uipath, just for you to check the differences.

Any ideas?
Thanks !!

Ui Path

Previous one was from UI path . This ine is from the tutorial

UIpath Academy tutorial

When you edit selectors, UiPath ‘Indicate Element’ feature tries to detect the most unique and indicative properties of any given component.
For example, it finds elements such as id or class (e.g. DIV).
Sometimes it may not show exactly the property you’re looking for. For this, you have the more advanced inspection tool - UiExplorer.
In UiExplorer you can check or uncheck some properties as per your requirement. Try using UiExplorer
You can access this by clicking this link in your Selector screenshot:
image

This is the UiExplorer window, highlighting the ‘Selected Items’ pane which has the option to select or omit properties.