New Introduction Course Bug

Team good morning

I write you because working on new tutorial of the Introduction to Uipath(Bucharest local time) when trying to modify the selector to the make it flexible with the question marks and wild card like in tutorial the Validation Part is not checking them, so I thought probably I was missfollowing an step but I even download the example in the course and it shows me same error I do not know who ti contact so I decide feedback over here.
If I did something wrong please let me know

Regardsselector

@Miguel_H1

Just use star and check it once.

          aaname = '*'

Still not working :frowning: (attach screenshoot)selector2

do you have the website loaded? where is this selector from? is it inside a attach browser or open browser?

@Miguel_H1

Could you please show me screenshot of original selector.

And also you included that wild card entries in URL value or by default it’s there in the selector ?

The one I am attaching is an screenshoot from the tutorial but is almost the same as mine(the only things that change is time. Everything else I leave it as default.

selector3

Yes, in fact it works until the Get Text, I opened browser and then proceed to use Get Text

i would just remove the aaname and not just use * in it…

Like this <webctrl * parentid=‘rso’ tag=‘DIV’ /> or only * ??

<webctrl parentid=‘rso’ tag=‘DIV’ />

Still not valid :weary:
selector5

if you use Indicate element and point it again, does it include back the aaname=‘21:22’?

Yes it get back but to the time that Bucharest have in this moment

so the only way to make this work is if you have the right value inside the aaname? it never works with the * in there? Is it just a “visual” problem or if you run the project with that validation error it works?

In fact is the first exercise of the rpa developer course so it explains that step is necessary to take anytime instead of the only time when scratch is done.Nope it does not work ,it does not show any error but it keeps compiling forever. What worries me is that is part of the RPA Developer course so is rare.

Thanks in advance for all your time

1 Like

I have the same problem but I just ignored it and robot works fine, shows current time in Bucharest in output in the end

make sure you have aaname=’*:??’ and when you validate, the website is ready showing the time and it will work.

While validating, the google search result needs to be open in the browser for UIPath to be able to validate the selector on the search result. It took me a while to figure this out even after reading this forum, so I wanted to clarify this.