Wrong result from workbook read range when the cell contains formulas

excel
activities

#1

Scenario:

/Got wrong result from workbook read range when the cell contains formulas

Steps to reproduce:

  1. using workbook read range to read the excel file into a datatable. the Cell G296 contains a formulas(B296-10) and the result of formulas is 10

  2. loop the datatable and using GetRowItem activity to get the value of G296, but the output is -10
    p2

Current Behavior:

the output is -10

Expected Behavior:

the output should be 10

Studio/Robot/Orchestrator Version:

Last stable behavior:
Last stable version:
Studio version: 2017.1.6435
OS Version:
Others if Relevant: (workflow, logs, .net version, service pack, etc):


#2

Are you sure you’re using the right row index? The datatable starts at row 0, so index 296 is actually the 297th row. This row is hidden and contains -10, because the referenced cell is zero or empty. For example, Read Range on this sample data:
image

Gives the following results using Output Data Table:

20,10
,-10
20,10


#3
  1. i am using column name instead index
  2. there is no hidden column/row in Excel

#4

Well, in your first screenshot I can definitely not see the row numbers 130–172, 175–232, 235–294, 297–355 and 357–429. Could you please check that the output of -10 is at DataTable row 295, which corresponds to Excel row 296, and not from DataTable row 296, which would correspond to information I cannot see, but for which my guess is that it is -10? As it is, I don’t have enough information to confirm that -10 is wrong.


#5

because this is a long list so i filtered it, there is no -10 in the list


#6

Hi,

I am also facing similar issue. Have you come across any solution.

Thanks


#7

Hello @AnjuChandran have you tried using Excel Scope read range activity.


#8

I tried using excel application scope and now its working fine…

Thanks @AkshaySandhu for your help.