“Write Range: The range does not exist.”

Hi Team,

We are getting an error “Write Range: The range does not exist.”

The UiPath version which we are currently using is 18.4.5 and UiPath.Excel.Activities is 2.6.3

Write Range activity is been used inside Excel Scope activity.
We have tried uninstalling & installing the activity package. Still getting the same error

Excel Scope Activity Properties are in the screenshot attached

The same piece of code is working fine in 18.1v, where the Write Range is been provided separately and not inside Excel Scope Activity

Kindly help us to resolve this issue.

1 Like

Hi @Selvasathya

keep the write range as nothing " " and mainly check (enable) the add headers


1 Like

Hi @Selvasathya,

1.First check the values present in the data table once.

2.Please close the excel that you are writing before running the bot.

3.Try giving small range like “A1:G8” and check…

Any doubts let me know…


–ensure that range is mentioned as “” if we are taking the full the excel data starting from “A1”
before EXCEL APPLICATION SCOPE use KILL PROCESS activity and mention the processname property as “EXCEL”
this will kill the excel application running in background as this error might occur when the excel file we are accessing is opened in the background

Cheers @Selvasathya

Hi Palani,

I am adding kill process before using Excel Application Scope. Tomorrow I will check the results and update you. Thank you.

Hi Palani,

I am still facing the same issue.

Did we try with workbook activities instead of excel
Cheers @Selvasathya

Hi @Selvasathya

Please check the input Datatable that you are writing to the excel, because in 2018.1 the write range works even for empty datatables, they write empty values to the excel file, but in 2018.4 when you try to enter empty value it will fail.

Hi @gouthamj

Thank you, this solution helped us to fix the issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.