Write range error

Hi All,

I am getting the following error in the write range activity while reading data from one excel to a datable and using the same datatable to write it into an excel which is not present and will be created by the bot having a custom tab name. The odd part is it is working fine on one machine but it’s giving this error when it runs on another machine.

Steps already tried:

  1. Closed Excel.exe process in task manager.
  2. Tried with both App integration and Excel write range but getting the same error.
  3. Restarted laptop and tried running it.
  4. Both the laptops are on Enterprise v2018.3.1 and have the latest version of Uipath.excel.activities (2.4.6863.3065)

Is there something I am missing or any solutions to this would be really helpful.

hi @Sayan,

Is it possible to attached the Excel file or equivalent sample to test ?


makes sure both excel file extensions are the same e.g. .xls to .xls

Both the excel files have the same extension. .xlsx

Please find attached the excel file and the .xaml fileSec30.zip (10.1 KB)

In Excel application scope, check the Visible property as false.