Write range activity - Error message "Range does not exist"

It would really help if you could recreate a dummy excel file that causes the issue. Maybe just one line with the same sample numbers will work to recreate the issue?

One way I would try to debug it would be to try and simplify the file until it starts working. There has to be something with the delimiters or something else that causes this issue.

1 Like

Check your Data Table that you are writing into Excel. You get this error if the Data Table is empty.

I had the same issue. I was reading queries from an excel and writing the query results into another excel. I had few empty cells at the end of the input queries excel and i was seeing this error.

Hi,

I have checked my DataTable and it is not empty. I have encountered this type of error in a few processes now, need to know why is this error occurring? I am using Excel activities package 2.5, tried using 2.6.3 as well but to no avail.

Hi,
I have found the reason for this error, which is even more confusing.
The “Range doesn’t exist” error occurs when there is an excel application scope within an excel application scope, and when I try to perform a write range in the inner excel scope, the error occurs.

Any reason for such a behavior? As this was working in v2016 studio. Currently in v2018.4.4 I am facing this error

Strange! I tested it on UiPath.Excel.Activities 2.6.3 (but on the latest Studio 2019.10) and it seems to be working: