Write Data in a Web Formular

Hi,

I have to enter data in a Table in Web Formular (SAP), but I can not use the “Type Into” Activitiy. It fails in finding the right cell. :frowning:

What works correct for a 100% so far is the Activity “Keyboard Shortcuts”. I’m using a fix field and a series of TAB-Key’s to get into the right input field. But how can I now write data into this field. Cursor is blinking in there. The only thing I would need right now is an activity which lets me write the data into it.

Any ideas, which one(s) I could use?

Thanks :slight_smile:

1 Like

try install this tool
Capture

How is this tool supposed to help me with my problem?
I’m not working with an Java-based application.

Hi @Daniel_Fichtner,

Have you tried using set text or a type into without a selector?

A set text works like a type into with simulateClick and can also work without a selector

1 Like

@Daniel_Fichtner

From your statement the fields are generating dynamic selector, but you can check in UiExplorer to handle this dynamic selector,

Can you share your selector, so that we can check

If we find a selector then there is no need of passing any hotkeys

For TypeInto you have the properties like stimulate click and Send Windows message, try enabling one by one

IF this not works then try with Set Text, also it has the properties, try enabling one by one and check

Hope this helps

Thanks

1 Like

Hi @william.coulson

Type Into without selector doesn’t work either :frowning:
What do you mean with “set text”?
I tried to find it in the uiPath-Documentation-Portal, but it seems that the search function is down at the moment :frowning:

Kind regards
Daniel

Hi @ksrinu070184

You can have a look at this topic: SAP & Anchors where I have posted some details about my problem. The only thing that works so far with a certainty of 100% is using Tab-Keys via Keyboard Shortcuts, but I can’t send the data with it :frowning:

Kind regards
Daniel

Hey @Daniel_Fichtner,

If a Type Into without a selector didn’t work then the Set Text may not work either, but give it a go. Search set text in the activities panel

image

1 Like

Hi @william.coulson,

wow. Thanks for the fast response :smiley:

Yes, you are right. Doesn’t work either. “set text” needs an selector, doesn’t work without :frowning:

Found “set text” after I installed the UIAutomation Package. I imported the Project from StudioX which uses the UIAutomationNext Package instead, but doesn’t include “set text”.

Hey @Daniel_Fichtner,

Try using a type into to initialise the hotkey tabbing. I have used this method before, but for entering instances of an array into text fields on D365. I can’t say I’ve used SAP so I’m not sure if that would work either

Hi @william.coulson,

I think that is what I’m doing already. Or did you have something else in mind?

I’m writing data in the first field and then use a TAB to move on to the next field. Works absolutely fine so far :slight_smile: Only Problem is now to write a text into this field.

Hey @Daniel_Fichtner,

Yes, you’ve implemented what I suggested. I wasn’t sure if you already had.

That’s all I had in mind, I cannot think of any other methods. Apologies.