Type INTO is not writing input text

I am going through UiPath training videos, in chapter-6 (Selectors) i am trying to write data into Automation Challenge fields, it is able to select the field correctly but not writing input text provided and not showing any error too. Could you help me with this.

Hi @ynerella

Are you able to use set text activity based on selector


yes @AshwinS2 i checked with set text activity too, but same result

Show the selector

Below is the Selector.

hi @ynerella

use anchor base activity in Automation Challenge fields as it changes in every refresh.


Happy Learning😊

Hi @Achal_Sharma,
Thanks for reply. I tried with Anchor stage also, but got errors too. Please see the below errors.

hi @ynerella

can you share me the selector of type into.

Here it is.


just keep the type into selector default that uipath had taken and re indicate the find element, the selector must on the ‘LABEL’ not on the ‘FIELD’.



and find element

and mark the solution if it solve😊

Hi @Achal_Sharma, i tried this one too but result is same. :frowning:
Selecting fields but not writing data in it.


i am sharing the sample workflow of the anchor base, go through with the workflow and do let me know if its work then mark it as solution.


Sequence.xaml (5.3 KB)

@ynerella use this selector and just use type into activity

make sure the aaname should be changed for every selector.

@venkatmalla6, @Achal_Sharma, Issue still exists. If needed i could provide my code. Let me know

@ynerella i don’t how you given the selector which i sent to you,it works for me and can i have selector which i sent to you.

@ynerella in for each row don’t use any activity other than type into activity and indicate the element which you want to fill now open the selector and click on uiexplore below you can see that and then click on indicate element indicate the field you want to fill and use anchor base indicate the anchor of the respective field make sure remove the id attribute.
say you want to fill first name now once open the uiexplore click indicate element and click the field of first name and click on anchor base and indicate the first name as anchor base now it will generate the selector with anchor base and in that selector uncheck or remove the id attribute.similarly for all the fields maintain the same selector but it vary for only aaname attribute only

Here is the flow part, Main.zip (3.7 KB)

hi @ynerella

so your find element was selecting the image input, and I had change scope from the image to UI Element and now it’s working fine. you can now copy that anchor base for further process.

Main.xaml (19.2 KB)

Cheer😊 and happy learning😊

and check on the solution if it works fine.


Thank you @Achal_Sharma @venkatmalla6 for your quick reply and support. Issue is resolved now. :slightly_smiling_face:
Issue is regarding some global variable.