Write Cell Range does not exist

Hello everyone, I hope you are doing well.

I have a specific problem with the “Write Cell” activity (screenshot). I want to apply the formula “=CONCATENATE(AM2;AN2;BE2)” for the whole column but when I run the robot it says “Range does not exist”. However, when I leave the range as it is but change the formula to something simple like “=1+2” it works. On the other hand when I put in the initial formula by myself (not by the robot) into the excel file it works too. That is why I wonder that the robot doesn’t do it correctly. Any ideas how I can solve this issue?

Best regards

Unless it has changed recently, I believe you need to supply a single cell rather than a range of cells (I rarely use the write cell activity and usually use write range instead, so this may not be true anymore)

HI @RandomGuy,

you need to do something like this

Use autofill range to drag formula to the last


I wrote in the cell I need ("BG2) and it still says Range does not exist

I did and it still says range does not exist :confused:

Can you share xaml and the file so that a solution can be provided

1 Like

I changed the original file because there are some private data but there is the same problem :sweat_smile:

Concatenate.xaml (5.0 KB) Error.xlsx (10.8 KB)

Hi @RandomGuy,

Error.xlsx (11.2 KB)
Concatenate.xaml (4.9 KB)

Please have a look, i made some changes and this code is working in my system

Well… :sweat_smile:

Hi @RandomGuy,

Just delete the project.json and open the file again + update the packages in Manage Packages.

I did it all and it still shows the same. Can you maybe take some screenshots of the code and properties?

just in the concate.xaml you provided replace your formula in write cell their and instead of semicolon put comma , something like

“=CONCATENATE(AM2,AN2,BE2)” and try

I changed the formula to the way you told me with the commas and I get a new Error “Write Cell: Exception from HRESULT: 0x800AC472”

Before Excel Application scope put a kill process activity in that in process name enter “excel” and in scope before writing to cell give a delay of 2seconds

I put again the simple formula “=1+2” into write cell and even that won’t work. The same error appears. Now I added the activities you told to add and it seems that I got into an endless loop because the process is already running 5 minutes :thinking:

Their is some issue in your excel file dude that is not letting write cell perform the operation , if you can share the Xlsx file i can have a look for what is wrong.

Ok I fixed the exception thing and changed the concatenate formula and added the commas. It runs but when I look at the excel file I just see “#NAME?” and the formula in excel says “=@CONCATENATE(AM2,AN2,BE2)”. Now I wonder where the “@” comes from :smiley: