Weird error with write range activity

excel
activities
p_solved

#1

Hi guys, I know this post could be similar at others, but no. Here is my scenario:

  • I have a robot which write an Excel report, it worked nice until yestarday. Here is an screenshot of my report.
    imagen

  • Well, the robot reach the write range activity and write the report. When it done 74 items correctly, in the 75th, it failed and give me this error: “The range doesn’t exist”. It never happened before.

  • In the write range activity, I have “C”+cont.tostring where cont is defined with an integer (“8”) and it is increasing in 1 unit for each item.
    imagen

I really apreciate your help guys… let me know if you guess why its hapening… Thank you very much guys!

Regards :mage:


#2

Hi @Pablo_Sanchez,
A little confusion with Write Range and above text. In the image starting cell is “B” +. But in the explanation it is “C”+. It is Ok .

  1. Before the write range please check the cont variable value by message box.
  2. Reinstall the UIPath.Excel.Activities.
  3. Try to use Write Range activity under the workbook.
  4. Use .ToString for each Data which is not a string value.

Regards
Balamurugan


#3

Hi @balupad14, sorry for my mistake with “C” and “B”. I guess that I have to reinstall the UiPath Excel activities, didnt try it.

Using write range activity under the workbook is a good idea but, it shouldnt fix my problem because it was working nice since months ago, never seen this problem before. I hope this weekend wont hapen again, and I wont able to upload new code, so I will reinstall the activities because thats whole I can do.

More than that, is weird to see a code that was working great and now is failing for this issue. It should be for Excel activities.

Thanks for your help @balupad14, regards! :mage:


#4

Can we have the wf and the excel file to test? Thanks!


#5

I’m sorry for my late response @Gabriel_Tatu. The error was produced by the old excel version. When I updated the versión it worked great.

Thank you for your support. Best Regards, :mage:

Pablo


#6

HI @Pablo_Sanchez,
Ok. It is good.
Regards
Balamurugan