Working with UiPath terminals

Using UiPath we are trying to connect it to TN3270 terminal to integrate it with Mainframe. In configure connection we mentioned ‘UiPath Internal’ provider and manually entered the IP address, Port and type(TN3270). We are able to connect (Status - connected) but unable to get the display. Can anyone help with it. Also can you please mention how to check whether UiPath has ssl/tls (transport layer security) capability.

Yes same problem i was faced many months ago.

please follow these steps then you will be able to automate.


1 Like

Hi ,
Followed the steps with ‘uipath internal’ provider but still it dint work.

Can you give me a scenario how manually that terminal app working. It is launching from a application ibm producer? I mean on just click it is automatically getting connected with ftp server? Right?

1 Like

Yes, on start of the terminal session we mention the details as in “ UiPath internal” Provider, IP address, Port and type TN3270 and on clicking ‘OK’ the session gets connected but unable to get the screen/display.

You have not gone through with that post i have mentioned you have to use IBM EHLLAPI provider and rest things already mentioned there. Please once again read the steps carefully and try it and let us know :slight_smile:


Can you please provide me with the URL from where I can download ‘IBM EHLLAPI’.

Hey @Joe

This provider comes with Uipath Terminal session activity supported providers list.

So to resolve this problem Do following things:

1. In terminal session Activity wizard select “IBM EHLLAPI” Option.
2. Check “Show client application”.
3. Click on “Attache to existing session”. and fill follwing details:
4. EHLL Dll = C:\Program Files (x86)\IBM\Personal Communications\pcshll32.dll
// Make sure you have installed IBM Personal Communication on that system for step 4.
5. EHLL function = hllapi
6. EHLL Session =A
7. EHALL Enhanced = checked
8. After Clicking you will get the terminal recorder and perform the steps and run it, this time it will work.


The above was tired to connect with
Using IBM EHLL standard*
Connection was in disconnected status , and error popup as “There was an error connecting to terminal.Error code Error”

Can you help me with this !


Well you can try with session approach as well. store session file in somewhere on the system and pass that file for connection with terminal.

and regarding above problem will you let me know where and when you are getting this problem? in which step?


Below are the steps followed to connect to Using IBM EHLL standard
Note : I have opened the HOD application and connected to the 3270 terminal

Problem is in the above screenshot at right side, the error is pop “There was an error connecting to terminal.Error code Error”
Can you please help me , why this error appears


will you let me know?

Your error code is also not returning any message.


I tired doing this opening the existing session of the terminal


i have same problem here, got error “Message: There was an error connecting to terminal. Error code: Error”
some help needed?, i tried this proposed ehllapi solution with and without existing session?

Hi Akash,

Can you pls explain me one thing - why should we use IBM EHLLAPI instead of IBM PC’s WS Profile. when we are having IBM PC installed and configured and working successfully on our systems.

And, moreover, if you help us in identifying the issue - whether it is in the WS Profile or Connection String or somewhere else?

Hey @Manish_V

both we can use but there is difference, my personal choice would be IBM PCS profile because with IBM EHLLAPI the session should be opened first because it uses existing session.

I was using that because for me with session profile it was not working so i did it with that.

the issue dependent on Terminal package and how it is calling api calls in the background.

what kind of problems you are facing right now?


Right now, there isn’t any problem.

But, I have analyzed that the connection string for IBM PC and EHLLAPI is having a very little difference and that might due to the some of the required information not available in the WS Profile.

Like, the Host Server IP is not provided WS Profile. But, it is required for establishing a Terminal Connection. This is manually provided while using EHLLAPI mode of connection. And, if we provide the same in the connection string for IBM PC mode of connection, it gets connected easily.

But, there is another problem, that we not using the IBM’s default keyboard setting. We use our own modified one. And, the folder location of this modified keyboard settings (.kmp) file has to be updated in WS Profile. This works fine when a human user is working. But, this keyboard setting fail to load / do not get utilized, while using IBM PC in UiPath. I think, the way we mentioned the folder location of this modified keyboard setting is not recognizable to UiPath.

I would request, if you have any resolution for this.

Was this resolved?

@Manish_V did you find a solution? We’ve got the exact same problem with the keyboard setting and have spent a lot of time already, struggling to find a solution. It would be very much appreciated if you could share the solution, if you found a solution.

Hello Aksh,

While downloading IBM Personal Commu… its asking for paid version. Do we have any chance to connect without that?