Notepad OK key greyed-out

Going through another example (link below), I downloaded the sample workflow and ran it.

It starts by opening run app, then types “Notepad.exe”. After that it is supposed to click the OK button, but the OK button is greyed-out, which stalls the workflow. This doesn’t happen if I go through the steps manually.

It’s especially puzzling, because you’d think they would test their own example before they published it. :slight_smile:

Hi @Kurt_Brummert

It’s possible that the same workflow behaves slightly differently on your machine because of some configuration difference. Can you try a combination of the ‘Simulate’ and ‘Send Window Messages’ options?
It’s possible that Windows can’t detect anything being typed even though you can see the typed text

I’ll give that a try and let you know. Thanks!

That worked when I switched it to SendWindowsMessages option.

…But now it’s giving me the below error. When I run it, it opens up Notepad now, but then sits there and doesn’t type what it’s supposed to. A minute later, it errors out with the message that it can’t find the user element that it just opened :thinking:

Message: Cannot find the UI element corresponding to this selector:

I had to re-do the TypeInto for Notepad and put it inside an AttachWindow.

The below file works. Fixing things that don’t work is a great way to learn, but if you have an audience of users who are beginners, there really ought to be an example that works the first time, especially in the latest Windows environment.

Thanks again for your help! :slight_smile:

Main.xaml (15.1 KB)

1 Like

Glad that is solved your problem.
Like I said earlier in my reply, I’d urge you to look at it as a configuration difference. In the example that you’re following, the reason for failure isn’t the wrong property being set on Type Into but the selector itself is different.
This can happen on different computers and there are different reasons for this to happen.
Selector from the downloaded example:

Selector after fixing it to match my Windows machine:

If you compare the elements in the ‘Edit Selector’ section on these screenshots, you’ll notice that my computer couldn’t see the property aaname='Text Editor' in the second row, which is why the selector shows invalid.

If you are yet to reach the ‘Selectors’ in your training, I understand your frustration. But, UiPath forum is a great place to get help with specific issues such as this one. I wish you all the best with your training :slight_smile: