Workflow not working in Virtual Machine

When i will run my Workflow which is build in local machine it’s working fine for me.If I run the same workflow in Virtual Machine its not working Please help me out.

1 Like

Hello @MahalingPatil,

You can see what kind of errors you are getting, and start troubleshoot them or post them here so we can help you.

Regards,
Husain

If i troubleshoot the problem in VM then it will not work in local machine.

1 Like

hmmm, weird.

I just developed workflow on my local machine and publish it to Orchastrator and it working greatly on both on my local and 2 VMs everything is fine.

I think you need to post more information about the error that you are getting, and why it is only work your local or VM. Why you do not develop 2 workflow one for the local and one for the VM.

Anyway where do you want the workflow to work eventually, develop for that specific machine

Regards,
Husain

@husain, you mean, we need to execute different scripts for different machines? If yes, are we not loosing script reusability feature. If no, could you please elaborate.

1 Like

@MahalingPatil, my scripts were also not executing on VM when VM is minimized. Could you please post the changes you made it to work on VM.

1 Like

No, as i said i use only one script.
when I developed on my local machine.

But I use Orchestrator and unattended robots.

you can use same script, and i think you have already use the same script on VM and local.

his post is lacking information.

1 Like

Agree! Thanks :+1:
I’m facing same challenge as @MahalingPatil, where i try executing same script on a VM thru Orchestrator, scripts is failing when it has to type into or click a element. I tried with using “Launch Workflow Interactive” activity as well. Ended with no luck.
Please find the attached script and screen shots.

ExecutingFromVM.zip (6.3 KB)

Any help highly appreciated. Thanks

1 Like

Perfect, thanks for all the info.

I have opened your workflow, i think you have done all the work and using the right activity.

I think i know where the problem is, the screen resolution on the vm when you run the workflow.

As I said you have used the right activity “Launch Workflow Interactive” but you did not set Screen Resolution in the properties.

you can use this website to find what is the development PC’s resolution and set it to the activity’s properties.

Hope this helped you,

Regards,
Husain

Thanks Husain, appreciate your help!
I tried setting Screen Resolution as you suggested, but the problem still persists. On minimizing VM its no more executing.

No problem,
I hope when you talk about minimize the window you are talking about Remote Desktop

If it is unattended robot, you dont need to minimize the window, orchestrator will kill the session. And the robot will do the needful.

I think it is designed like that. Simler thing happed to me when i log back to the vm after starting the job.

But when I dont log in, the robot finishs the job

I hope you try with out login to the vm and see the result.

Best regards
Husain

Hi Patil I also faced the same issue but i overcome this issue with selectors, i mean you have to edit the selectors with detailed then it will run on any machine. For example here you have to select the all the dependecies then it will work fine.
image

1 Like

I am having the same issue that I get error for click activity when VM is minimized, but it runs fine when remote desktop is maximized. Please help with selectors!

Hi, did you try these options?
image

Hello @bcorrea!
I added simulate click to every action in my process and executed via orchestrator. I am now getting a different error.

Yes, thats the right error to have :slight_smile: see below:

Doing this now, I will let you know how it works out! Thanks

2 Likes

I have been facing the same issue… But this solution seems promissing does anyone else tried?

1 Like

Thanks, it’s working.