Work Around On Robot Slow Responding

robot

#1

Scenario:

  1. Having some trouble where robot responds slow (about 30 secs each time) on a certain web app. Details asked before here.
  2. No Orchestrator, UiPath Robot only.

Question:
I can’t seem to understand why robot is responding slow, but I think I run out things to try (and I a little believe it has something with compatibility of UiPath and the web app still cannot figure it out exactly). But the robot responds slow, and the client’s not happy about that. Any temporary work-around may be we can timeout the robot itself when it takes longer than expected time, gracefully I hope?

Cheers.


#2

Hi @whyyouandi,
I have faced this situation in past 2-4 times
But I used to restart the ui path robot service and gave it 10 minutes or so then restarted my system and it seemed to work fine.
But if it still doesn’t sort the issue then uninstall ui path clear registry files and Install again.
This I think should sort the issue.


#3

Hello @prassin6, thank you again for your response.
Sadly, tried with no result. I even installed the robot on 3 of other clients’ PC and all of them behave the same :frowning:


#4

@whyyouandi, Could u please advise which browser u r using and its version.

Is it the latency with every activity that the Bot executes or just once specific activity.

Could you please advise if the latency is experienced only for a specific website or is it for all the web sites .

Which windows version are you using.

Has this happened before or was it working fine ??


#5

Hello @prassin6.

Machine: Windows 10
Browser Version: Internet Explorer 11
Happens: By now, tried it in 7 PCS (3 with only Robots installed and 4 with Studio installed). All of them behave the same. So, I think the possibiliy is that the problem relies on the compatibility between a certain website and UiPath.
When It Happened: From the first time of the development, till now. Never been working fine on that activity before.


#6

Hello @whyyouandi :slight_smile:

Select any activity and on the right hand side - you will find the properties pane.
The properties pane will have a property named Target when u click on it you will see a sub property named -> Wait For Ready

Please set Wait For Ready to NONE and run that activity and see if it executes properly without latency.

If it does not help, then set Wait For Ready to COMPLETE and check again.

Hope this helps :slight_smile:


#7

Thank you for your reply, but there was not activity to try that actually.
Will send you the simulation flow later, for now thank you for your continuous support.


#8

Hi @whyyouandi

I have exact the same problem. Did you manage to solve yours?

Kind regards,
Tom