BOT Running very slow on Internet Explorer

robot
p_qa

#1

Scenario: The BOT is executing the activities very slowly and is running very slow.

  • Every step takes 35 seconds approx to execute.
  • This also creates behavioral issues with the way Ui Path is running.
  • I am using trial version and installed it on Win7.
  • I have created a simple work flow and there is no delay activity that I am using, and running it on Internet Explorer 11 and it takes ages to run.

I have restarted the Ui Path robot Service several times as well.

Tried restarting the application as well - No joy!!

I have tried to re install the Ui Path as well.

Current Behavior: The BOT takes approx 35 seconds to do one activity and make a progress to next one.

Expected Behavior: The BOT should run smoothly and it should perform activities smoothly.

Studio/Robot/Orchestrator Version: Ui Path Platform - probably latest.

Last stable behavior: It works fine when I start the system and then I observe latency again.
Last stable version: Last week
OS Version: Win 7

Any help would be appreciated.


Bot starts getting delayed after a certain point
What is Done in the Backend of UiPath Inside Monitor Events?
Slow execution of the program!
#2

Is this isolated to certain websites or all of them? I don’t have issues usually, but occasionally certain websites, for whatever reason, don’t work well with UiPath.

Namely, opening PDF documents on the web from a specific site has provided delays in UiPath selector recognition; like it sees the window or element but doesn’t actually perform the action for another 30+ seconds. In my case, it’s very isolated, though.


#3

Interesting.
I’ve started experiencing the same from today. No updates that I’ve noticed anywhere.
2017.1.6435 / Win7 / IE11

Especially the acme-test interactions turned into complete joke, as robot is doing 1 action / 2 minutes.


#4

Hmm, strange behavior since you say it’s out of the blue. And I noticed that it’s happening on Win7. Needs to be investigated.

I have the CE 2017.1.6522(which is the latest version), Win10 and IE11 - i could see no difference in Robot’s “speed”.
Andrzej, i ran my Calculate Client Security Hash workflow on acme-test and executed in 00:07:48 minutes. So 2 minutes is a lot of time for 1 action indeed.

If you guys notice anything else that could help the QA team reproduce, please write into this topic. Thanks!


#5

For the Calculate it wasn’t a big issue.
The Report one was, though - it seems that it triggers after a file download popup (no matter if you actually download it or press cancel). Other popups don’t interfere at all.
After that popup every action takes a little bit over 120 seconds. It’s too consistent to be a conincidence and it looks like a timeout of some sort, but I can’t pinpoint what exactly.

Worked around by adding a RefreshBrowser after each downloaded file, but this is a very fragile work around and outside of the Acme-test systems is not really feasible.

Btw - previous post was from work, I’ve checked on home pc as well - 2017.1.6522 CE / Win10 / IE11.
Same situation.

I’ve noticed also that the caching seems changed, as there were some UiElement no longer valid errors as well. Didn’t do much on CE / Win10 lately, so can’t say when the change happened, but I don’t recall having issues like that in the past. Will let you know in a separate topic if I’ll be able to give something useful there.


#6

I’m noticing this issue now with a Process I have been running today to test Error Handling that wasn’t there before, so it is reloading the website and data when I throw an error. It seems random but frequent. In this case, it’s loading the table on a website and it is stalling for like 2 minutes before either extracting the data or clicking the link within the table. I have not changed any part of that workflow.

But, it doesn’t only stall there. Sometimes it stalls on inputting a textbox right before it loads the table.

So for me it’s kind of random when it happens, but seems to be related to the fact I’m doing a loop on reloading the website. It does download a file beforehand, but no popups; just the Save Dialogue.


#7

Hello @ClaytonM , @andrzej.kniola, @ovi

This problem seems to be occurring with multiple web sites.

But I am unable to figure out , the same UiPath work flow when we run on a different system (Win 7 Lenovo T460) ,
works like charm and creates no delay whatsoever.

I dont understand why is it not working on the original Laptop (Win 7 Lenovo T460) and both the laptops have same configurations.

Could it be system specific issue?
If yes , could you please advise how do we progress with this.

Warm Regards,

Ptrashant Singh


#8

Hi!

What if you try setting the WaitForReady property from Interactive to None?


#9

Tried it, didn’t make a difference on any level that can be set.


#10

Hi @ovi, @andrzej.kniola ,

Thank you for giving your suggestion this topic :slight_smile:

I have tried to format the System and installed a Windows 7 OS again.

After that, I installed UiPath again on the same system and now it is working smooth.

I don’t really see any delay as such and it works like a charm.

Warm Regards,

Prashant Singh


#11

any solution for this issue.
even though UiPath can find the web element, it uses all the timeout time that it has. as a standard 30 sec, if reduced to 2 sec, it will do the action after 2 sec. this is not optimal.
error is in 2017.1 SP1


#12

We tried to perform similar steps at our end but could not replicate the issue.

Could you please confirm if this is limited to single process or to all the website in IE.

Can you test with any other website like google or amazon etc to see if you face the same issue.

Also can you test with any other browser if you find similar kind of behaviour

This is required to check if this issue is limited to a particular environment , browser (in this case IE) or technology specific websites.


Advanced assignment 2 the robot came to slow after save one report
#13

We tried using the WaitForReady=none option and it fixed the issue.


Open browser activity in uipath issue Cannot communicate with Internet Explorer browser
#14

Hi!

Yeah, I would say the problem is actually the WaitForReady = INTERACTIVE property.

I saw the same slowness problem in one portion of one screen in the application that was being automated.
In some cases, when it was changed to COMPLETE or NONE, that fixed the problem,
but what the option had to be seemed to depend on the computer, so maybe the UiPath or
Internet Explorer version was different.

The portion of the web page, where the slowness appeared, seemed to be dynamically generated, so
maybe this has something to do, with the page or element loading on webpages. I would have expected
though that the INTERACTIVE option would have been the fastest, instead of the slowest, since it waits
only for a portion of the page to be loaded as far as I know.

I have no clear specs, but this is known about the systems, where this problem occurred:

Browser: IE11
OS: Windows 7


Open browser activity in uipath issue Cannot communicate with Internet Explorer browser
#15

I have exactly the same behavior at the the same exercise (Download monthly report). In the beginning it runs fine. In my case I used an example that had no reports available up to July. Then at July it finds a report, downloads it and every action after that is slow and takes roughly 30 seconds.

Weird thing is, if you Stop (F12) the workflow during execution and try to run it again from the beginning, it will then be slow from the beginning (so also Jan - June in my example). To reset the whole machine, you then first need to Close Internet Explorer AND UiPath Studio.

Could there be some bug with the For Each loop or the activities inside the Else part?

WaitForReady=None seems to speed up again, but Interactive and Complete sometimes necessary (e.g. Vendorinformation in the training environment).

@ovi Testing on Windows 7, IE11 and Studio 2017.1.6522


Academy 2, Assignment 2
#16

I am facing the same problem. However, it got solved by setting WaitForReady = None. This is probably just a temporary solution, or could this work long-term? What are the drawbacks of using this “quick fix”?

When downloading monthly reports from Acme-test.com, it suddenly get a lot slower.
Windows 10, IE11, Studio 2017.1.6522.


#17

@ovi @Bolletje @andrzej.kniola

I ran into the same problem and immediately I say, “Windows Server 2008 R2” and “IE11”
It is clear that the problem is “IE11”

The operating system does not matter


#18

Thank you all for this discussion. I have been breaking my head for weeks to figure out the issue. As most of you have isolated that this delay is happening once we have interacted with a file download dialogue. Quite surprised to see that this issue have not been resolved yet!


#19

hi, i haver the similar problem, but for example, when i run olnly this (System1_CreateYearlyReport.xaml (32.2 KB)
)process for create yearly reports whitout the main process. it was executed perfectly, and it was created this report, (Yearly-Report-2017-FR065748.xlsx (8.0 KB)
) i dont know why failed when excecuted the main process


#20

I have the same problem.